LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 10-12-2002, 02:10 PM   #1
lakshman
LQ Newbie
 
Registered: Aug 2002
Location: trichy
Posts: 21

Rep: Reputation: 15
start xwindows


i changed the runlevel from multi user to single user
by typing linux s at the boot prompt ,but i started 2 services
namely
1. network
2. xfs
but it 's starting the xwindows environment when i give "start x "
i am wrong somewhere ,plz do give a proper reply
 
Old 10-12-2002, 02:21 PM   #2
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
'startx' one word - no spaces. It might work if the XF86setup is conifured properly.
 
Old 10-15-2002, 06:10 AM   #3
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
depends on your distro

look in /etc/rc.d/rc1.d

see what starts with S

try init 1
 
Old 10-15-2002, 11:41 AM   #4
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
You should have something like this


S00single
S17keytable


everything else should be starting with a K

unless of course you have no such file. In that case your distro does not work that way at all, and you need to look in rc.d at the script that matches the name in /etc/inittab on the line like this

su:1S:wait:/etc/rc.d/rc.K

and in this case look at /etc/rc.d/rc.K
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't start xwindows ust Linux - General 3 01-17-2005 09:05 AM
XWindows won't start !! netkepala Linux - Networking 5 08-31-2003 05:01 AM
Can't start xwindows juno Linux - General 3 12-18-2002 02:21 PM
Can't start xwindows juno Linux - General 2 11-29-2002 03:07 AM
Can't start xwindows juno Linux - General 6 11-17-2002 01:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration