-   Linux - General (
-   -   SSH not setting Display variable (

lapope 09-01-2008 10:57 AM

SSH not setting Display variable
I just purchased an asus eee pc specifically for the purpose of remote logging in to other computers. I am using the default ssh settings that came with the xandros operating system, and they don't seem to be setting the display variable properly. This is what I get when I ssh using X11 forwarding:

ssh -l -X
Last login: Fri Aug 29 11:09:42 2008
DISPLAY: Undefined variable.

The problem is not with the remote host, I have successfully ssh'd into it from other computers before without this issue.

What do I need in my ssh_config file or anywhere else that will automatically set up the display variable like it's supposed to?

tredegar 09-01-2008 12:06 PM

I am not sure about the error you are getting, but what happens if you enter env | grep DISP in a terminal on the eee?
It should return something like DISPLAY=:0.0

I got fed up with xandros on my eee701 and put kubuntu 8.04 on it ;)
Details are on the eee wiki at

lapope 09-01-2008 12:18 PM

I tried that just now, and it did return DISPLAY=:0.0
The problem is only when I try and open something like an xterm or emacs window while ssh'd into another host.

tredegar 09-01-2008 12:40 PM

OK, $DISPLAY is set properly.

I don't know why this is happening. I gave up on ssh -X (remembers... have you tried ssh -Y ?) because I found using a vncserver and vncviewer both easier and prettier. You can install these on your eee, but I think you might have to enable the Debian repositories (see the wiki link above).

Many of my PCs start up a vnc4server when they boot, then it is easy to connect to them remotely. Otherwise I just ssh in, start a vnc4server, exit, then connect to it with xvnc4viewer

I realise I am giving you a "workaround" here, rather than answering your original Q, but no one else seemed interested.
"If it aint broke, fix it till it is. Then find a "workaround" ".

lapope 09-01-2008 12:57 PM

Thanks, a workaround still counts as a solution. I think I'm just going to give up and go the way of ubuntu. On a previous laptop (a sony vaio) I had no problems sshing with ubuntu until an upgraded version stopped seeing my ethernet card. Here's hoping that doesn't happen again. I'm tired of struggling with this xandros thing, even the advanced desktop is obnoxious.

Thanks again, and if anybody else has another way I'd love to hear it. This problem might crop up again or for someone else.

tredegar 09-01-2008 01:46 PM


This problem might crop up again or for someone else.
I searched. Nobody else seems to have this exact problem. But maybe they have abandoned xandros, or are using vnc or aren't using ssh -X from the eee's xandros.

All times are GMT -5. The time now is 09:25 PM.