LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Specifying IO scheduler at boot (https://www.linuxquestions.org/questions/linux-general-1/specifying-io-scheduler-at-boot-260013/)

stonecrest 11-27-2004 10:20 PM

Specifying IO scheduler at boot
 
This is frustrating the heck out of me. I just installed Yoper and when I load it, my computer freezes at "using cfq io scheduler". When I first installed it, I noticed that it said "using deadline io scheduler" and that seemed to work, so I'd like to switch to deadline.

I've tried searching everywhere but I can't figure out how to switch. Every website I find just says to use the argument "elevator=deadline" at boot up. What does that mean?? When I boot up, grub comes up, I choose the linux distro, and then it freezes. At what point do I specify this argument?

I have a live cd handy in case I need it but I can't figure this out. Please help, thank you.

Scott

mritch 11-28-2004 04:55 AM

it seems your kernel is compiled without support for the cfq schedular.

there should be some way to pass arguments to the kernel. i use lilo myself and can open kind of command prompt right after the bootloader loads and gives me a choice. in grub there sure should be something similar. so try shift or ctrl keys or better read the documentation that comes with grub.

now append the "elevator=deadline" to the name of your kernel and it should work. other schedulars are cfq / as / noop.

however, i havn't seen a standard kernel without deadline support so far.

sl mritch.

stonecrest 11-28-2004 12:16 PM

Thanks mritch! I've actually given up on grub and gone with lilo but I'm still having trouble with this. This is my current lilo file (I have a dual boot with WinXP):

Code:

prompt
timeout=60
default=YOS
vga=791
boot=/dev/hda

lba32

bitmap            = /boot/yoper_boot.bmp
bmp-colors        = 1,,0,2,,0
bmp-table          = 120p,173p,1,15,17
bmp-timer          = 254p,432p,1,0,0


image=/boot/yos
label=YOS
        read-only
        root=/dev/hda7
append = "elevator=deadline"
initrd=/boot/initrd-2.6.8.1-3.img


other=/dev/hda1
label=Windows

Yet when I boot into linux, it still tries to use cfq io scheduler and freezes! Did I not add this correctly? Or is this getting overridden somewhere else?

Scott

mritch 11-28-2004 05:29 PM

it does look right. however try to specify the append option global:

[...]
append="elevator=deadline"
default=linux

image=/boot/vmlinuz
label=linux
[...]

it normaly shouldn't make any difference, but .. :)

if this still won't work, try one of the other:
"elevator=noop" / as or use another kernel. i asume the kernel you are using is a prebuild. there is a file called config-2.6.... with your kernel. do the following to know if the schedulars are compiled in correctly:

# cat /boot/config-2.6.... | grep IOSCHED

it should give info on that.
use an other kernel or roll your own if it keep failing. can you give any other information about the message when the system freezes?
is it sure it's the schedular (the kernel itself IS able to choose another if cfq has never been compiled in)?

sl mritch.


All times are GMT -5. The time now is 04:01 PM.