LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 09-09-2003, 12:49 PM   #1
Agifem
LQ Newbie
 
Registered: Aug 2003
Distribution: RedHat
Posts: 6

Rep: Reputation: 0
Unhappy Special characters issue


I have an unusual issue : I'm french, and it is normal for me to sometimes name files with special characters like é, è, _ etc ... on my Redhat 7.3, there seemed to be no problem with it, but with my newly installed Redhat 9, such characters triggers severe issues. Messages containing such characters are simply not show in ayttm, files with names containing those are incorrectly show ("s?curit?" instead of "sécurité"), and it even happens to directories, which are inacessible from any program until I rename them. And renaming such directories is not an easy task.
In fact, pretty much any program is affected by this, even web pages shown in browser, or the simple console mode in Ctrl+Alt+F1.

Does anyone has any idea of what the problem is and how it can be solved ? I would be so gratfeul for any help.
 
Old 09-09-2003, 01:41 PM   #2
Bebo
Member
 
Registered: Jul 2003
Location: Gteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 31
After a fresh installation of Mandrake 9.1, I had similar problems with the characters; for instance I got nothing when I pressed the keys special for my language, Swedish. I had to change the SYSFONT in my /etc/sysconfig/i18n to the correct key table. My i18n now looks like this:

Code:
LC_TELEPHONE=en_US
LC_CTYPE=en_US
LANGUAGE=en_US:en
LC_MONETARY=en_US
LC_ADDRESS=en_US
LC_COLLATE=en_US
LC_NAME=en_US
LC_PAPER=en_US
LC_NUMERIC=en_US
SYSFONT=lat1-16
LC_TIME=en_US
LC_MEASUREMENT=en_US
LANG=en_US
LC_MESSAGES=en_US
LC_IDENTIFICATION=en_US
However, this didn't allow me to have "strange" characters in filenames. This I could change by fiddling in my fstab. There is an options there that sets iocharset=utf8, which doesn't contain all the characters one might want to use. At the moment I don't remember if I just removed that option (I DON'T think I did that) or if I changed it to lat1-16, just as in the i18n file, or something like that. Maybe there is a simpler way.
 
Old 09-10-2003, 12:29 AM   #3
Agifem
LQ Newbie
 
Registered: Aug 2003
Distribution: RedHat
Posts: 6

Original Poster
Rep: Reputation: 0
Well, I'll try that ; status on next reboot, thanks for advices.
 
Old 09-15-2003, 02:45 AM   #4
Agifem
LQ Newbie
 
Registered: Aug 2003
Distribution: RedHat
Posts: 6

Original Poster
Rep: Reputation: 0
I changed the /etc/sysconfig/i18n SYSFONT parameter and it had no effect. I added the iocharset=lat1-16 line in my /etc/fstab and it wasn't accepted (mounting failed), so i removed it.
Does anybody has any idea ?
 
Old 09-17-2003, 12:42 PM   #5
Bebo
Member
 
Registered: Jul 2003
Location: Gteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 31
Hey,

There is a thread on something similar that might help you out a bit:

http://www.linuxquestions.org/questi...threadid=93098

Cheers!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Special Characters SimeonV SUSE / openSUSE 14 07-07-2006 01:29 PM
special characters greenbox Linux - Software 9 12-23-2005 07:33 PM
File Copy Issue-Special Characters fortezza Linux - Software 1 11-14-2005 07:16 AM
Special characters consty Programming 3 08-07-2005 05:53 AM
using special characters one_ro Mandriva 5 11-04-2004 08:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 11:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration