-   Linux - General (
-   -   Sound Problems (cd player, flash, gaim, possibly related issues) (

mcmillan 07-18-2005 12:47 AM

Sound Problems (cd player, flash, gaim, possibly related issues)
I recently switched from windows to Mandriva 2005 and am liking it except for a couple sound problems. When I try playing an audio cd the player GUI opens and will look like it's playing but no sound comes out. Playing MP3s works fine both from the hard drive and off a data disk. When I open the player (gnome-cd) in the console I get a message saying "Generic IO error" once I start playing the disk. I've tried playing it in xmms and it does the same thing, but without the error message. In reading some of the other postings here I noticed that there can be problems caused by not having the audio cable plugged into the motherboard so I checked this and it looks ok.

At first I thought there might be a problem with wav files since I wasn't getting any sound from gaim either, but wav files work fine otherwise. I changed the sound from the default to specify a particular sound and now it plays it when I push the test button, but not any other time.

The last sound problem I've been having is with flash movies. I've installed the flash plugin for firefox and it will play the video fine, but with no sound.

I don't know whether or not these three issues are related, but I'd appreciate any help someone could offer. Thanks

floppywhopper 07-18-2005 05:17 AM

What hardware are you using
Mobo & processor spec
Soundcard specs
anything else relevant


mcmillan 07-18-2005 10:17 AM

The soundcard is Intel 82801AA 810 Chipset AC'97 Audio Controller
Processor is a 1.1 GHz Pentium 3
I'm not real sure about the motherboard. I found the chipset controller is 82801AA 810 Chipset SMBus Controller, this sound motherboardish to my newbie senses, maybe it can give a little clue. I have to go to work in a few minutes, when I get home I'll spend a bit more time looking. Are there any other names the board could be called in the hardware manager or is there another easy way to look this up?

mcmillan 07-21-2005 11:29 PM

I still haven't been able to check the mobo. According to the intel website I should be able to keep the BIOS screen up by pressing esc in order to see it, but it still just flashes by real quick and I can't see it there. I even tried opening up the case but didn't see any obvious indicators.

I was able to get the flash sound to work by reinstalling the plugin, but gaim and cd player still doesn't work

floppywhopper 07-22-2005 01:21 AM

Have you been into hard drake and had a look at the sound card there
make sure you are using ALSA drivers


mcmillan 07-22-2005 04:20 PM

I didn't see anything in hardrake saying whether or not the driver was alsa. I realized I didn't even know whether or not I had the alsa driver installed so I looked in the package manager. All that came up with the name alsa in it was libalsa2 and libalsa-data, and there was a lot of other packages available. I installed these and now I have an alsa player which will play cds, but it doesn't seem to work on the other players. (though one cd seems to cause the alsa player to close, with an error message saying "segmentation fault (core dumped)" At first I thought this might be a problem with it being a burned cd rather than a commercial one which was the first I tried, but two other burned cds work. This is a big improvement, but still would like to figure out what's going on in case other cds don't work also.

Haven't had a chance to test anything with gaim to see if this fixed things (One idea I just had that I don't know if it means anything or not is the command associated with the gaim panel icon that Mandriva created says "soundwrapper /usr/bin/gaim" I'm wondering what soundwrapper means)

suurimanne 08-13-2005 07:14 AM

I have similar problems
I have similar problems with my audio, only with Flash player. I have the same soundcard, but it really doesn't want to work the
way it was supposed to. In flash the sound gets out of sync and plays in triple speed. I wonder how i could fix this.

Macromedia support says that Mandrake is not supported. :D What kind of idiots do they have working in there!?

Well to answer to your problem might be using some kind of soundserver, it is used to mix the sounds coming from various programs and it will write it into the sound device. That way, the sound device won't get occupied, and many programs can play sounds at the same time.

If you use KDE, you should activate Arts sound server if it already isn't activated. Xmms has arts soundserver plugin. Install that from the rpms.

Hachi-Roku 08-16-2005 02:16 AM

Not distro
Its the mobo with that sound card i have that mobo aswell and flash doesnt work for sound either...i still need to try a cd..but i know that my AMSN is supposed to have sounds :( currently running suse 9.3 and well i havent been here in awhile its good to be still a nub

mcmillan 01-03-2006 10:56 PM

So I'm resurrecting this thread. Not long after this I ended up getting a new computer. Sound was working fine in ubuntu 5.04, but I just upgraded to 5.10 and it looks like I'm having a similar situation to what happened before,which is why I went searching for this since I thought this was happening when I first installed ubuntu, so I hoped to find how I solved it.

So it's now a similar situation, I can't play any audio cds except using alsaplayer. Using gnome-cd in the terminal I get an error saying that "Could not open resource for writing" and does nothing else, the other players I've tried don't show any error messages, but cccd will look like it's playing with no sound.

If the cd is an independent problem using alsaplayer is an ok solution for me, but like before I don't seem to have other sounds, specifically thunderbird and gaim. Playing mp3s works fine though.

My new soundcard is built-in to my MSI K8T Neo-FSR motherboard with a AMD Athlon64 3000+ processor.

All times are GMT -5. The time now is 01:50 PM.