-   Linux - General (
-   -   Sound problem fix (

nextekcarl 10-03-2004 11:58 PM

Sound problem fix
I wanted to post a fix here that may have caused problems for people under many different distros regarding sound suddenly not working for some reason. I tried Mandrake 10, and Fedora Core 2, test 3, and others, all detected my sound card correctly, but only Knoppix actually played any sound, so that is what I used on my system (did a full install but kept the auto detection for hardware.) All was good, until sometime after using Synaptic to do an 'smart upgrade' my sound quit working. Installed the newest ALSA stuff off the ALSA-project site, and still no sound. Finally after looking around at different forums I found something that worked. So if you are having problems, go into KDE and look under Multimedia at KMix. If its not sunning, start it and a speaker icon should so up in the lower right part of the screen. left click on it and make sure the sound is not at zero. Then right click on it and make sure the other more specific settings are also not at zero (all of mine were for some reason). Once you adjust these check your sound out (I like Audacity for this purpose). If anyone knows why this is happening (maybe something I upgraded or installed sets this stuff to zero?) Anyways, it took a long time to find this answer so I wanted it to be easier for other newbies like me.

David the H. 10-04-2004 08:33 AM

Congratulations on figuring it out on your own. That's almost always more satisfying than simply getting a quick answer, even if it's more frustrating at the time. You get to learn more that way too.

What you've discovered is that Linux systems always start out with the sound levels set to zero, something that does cause a lot of newbies to stumble. I don't know why it's that way, but it is. Hopefully your post will help a few others out.

And here's hoping your next challenge is just as successful. :)

All times are GMT -5. The time now is 06:19 PM.