-   Linux - General (
-   -   sound device not working (

newbie007007 05-21-2005 03:25 AM

sound device not working

I am using FC3.
Suddenly my xmms is not working.
It is sound device is used by other program.
Even after rebooting the same thing happening.
When i started mplayer ,a message came saying that "Error initializing Default sound device and null output device is used." and presently mplayer is working.

Plz help me fix this error.
Thank you.

kornerr 05-21-2005 03:44 AM

ALSA is output plugin?
Intel-on-board souncard?
What kernel?

newbie007007 05-21-2005 05:25 AM

kernel 2.6.9-1.667.
intel onboard soundcard.
alsa output plugin.

thank you.

mkoljack 05-21-2005 06:03 AM

If you are using various multimedia applications all using the ALSA output device, you will get these error msgs. So, what has worked for me is to set amarok == alsa output, xmms == arts output, etc, etc. And even then the error message sometimes occurs. I either restart ALSA and/ or reset arts/system sound. Only takes a second and I'm back to listening pleasure.

Good Luck.

kornerr 05-21-2005 07:11 AM

1) You should have "~/.asoundrc" with the following content:

pcm.!default {
    type plug
    slave.pcm "dmixer"

pcm.dmixer  {
    type dmix
    ipc_key 1024
    slave {
        pcm "hw:0,0"
        period_time 0
        period_size 1024
        buffer_size 4096
        rate 44100
    bindings {
        0 0
        1 1

ctl.dmixer {
    type hw
    card 0

2) arts is said to be s**t, so turn it off;
3) in xmms Preferences do the following:
a) in Audio I/O Plugins tab:
set ALSA as Output Plugin;
press Configure;
in Device settings tab set Audio device to "default";
in Advanced settings tab unselect "Mmap mode";
b) in Options tab:
select "Allow multiple instances";
4) Also you may not have an access to audio device as an avarage user. This way you should add yourself to audio group:
Open /etc/group;
find a line with such content:

and change it to:

instead of kornerr place your login name, of course
5) Reboot and ENJOY;)

I've found that arts is not s**t. So turn it on!

mkoljack 05-21-2005 08:28 AM

Thank You Kernerr
Wow Kernerr--

Thanks so much. I also did as you suggested. All the multimedia now works in ALSA with no busy messages. No more arts. I appreciate it.


kornerr 05-21-2005 09:29 AM

Glad to hear "thanks" from you, mkoljack. But next time I ask you to not mistype my nickname;)
Just copy/paste the nicknames which you want to use - this way there won't be any mistakes.

PTrenholme 05-21-2005 10:53 AM

Yes, it looked like a good fix. But when I tried it (with the suggested .asoundrc), my ALSA driver barfed, setting output to /dev/null, as described above.

On the other hand OSS and TOSS both work fine. (Enligtned produces a "fuzzy" test sound, but it did work.)

Bottom line: I don't think ALSA is quite yet ready for prime time. The developers should, IMHO, look at the OSS code. It seems, to me, to be much more robust.

By the way, I believe you are supposed be able to set a system-wide asoundrc in /etc/ which might be useful for a system with multiple users. Igf ALSA actually worked.

mkoljack 05-21-2005 12:34 PM

Oops, sorry kornerr. Thanks for taking time to help us. PTrenholme -- ALSA is a fantasic output in Linux and it handles my external USB sound card SB Audigy2 NX. My point is there is a solution for you.

1. Be sure the .asoundrc file is in /your/home/.asoundrc directory
2. You may need the latest ALSA drivers, which was the case with me.

Those can be retrieved from the ATrpms repository for Fedora 3 and they work very well.

I'm posting again because I worked very hard to get sound working and it sounds like you are so close. Keep working at it. Fedora 3 is a fantastic distro. Kornerr had the last piece to my puzzle, God Bless him and thanks again Kornerr -- sorry for mispelling!

Good luck.

kornerr 05-22-2005 01:58 AM

mkoljack, don't bless me;)
I'm not genius at all, I'm just crazy about asking quesions on
The first (and the only) man who helped me with ALSA was keefaz in Slackware thread
Thanks to keefaz!:)

PTrenholme, read the second post in this thread and give me the answer;)

And one good advice: visit sometimes Slackware, Gentoo, Debian and other "similar difficult distro's" threads - guys there are much smarter than we are;)
And, of course, try Slackware, Gentoo, Debian (of wich Slackware is easier for Linux beginners... like me:))

newbie007007 05-23-2005 04:19 PM

It has really been great to learn things from you all.
I am a newbie to linux.
My xmms is working fine.
Can anyone of you tell me is there anyway by which i can listen to two audio files simultaneously??

Thank you

kornerr 05-24-2005 08:03 AM

All what is described in post# 5 will help you. But only if you use ALSA as output plugin in all multimedia apps.
E.g., I can listen simultaneously to xmms, mplayer, (g)xine.


I am a newbie to linux
We're all;)

mkoljack 05-24-2005 01:07 PM

Follow kornerr's instructions as stated in post 5. You have the abilty to play anything you want then through ALSA. It works perfectly. Be sure to turn off arts.

Good Luck!

PTrenholme 05-24-2005 08:25 PM


Originally posted by kornerr
snip . . .
PTrenholme, read the second post in this thread and give me the answer;)
snip . . .

Well, just because I'm retired now, with lots of time on my hands, I decided to see how the final test release of FC4 was working. Interestingly, "out of the box" the sound seems to work without a hitch. (And there are lots of real cool improvements over FC3 in FC4.)

Anyhow, my sound needs are quite minimal (since my hearing's damaged from too much gun discharge noise in my youth) so I'm happy with [T]OSS on FC3, and ALSA on FC4. So, thanks for the offer to help, but I'll just let it slide for now.

ravee 06-03-2005 09:07 AM

I had some problem with the sound card too. And I fixed it by installing alsa sound drivers. I have detailed it so that I will remember it at a future date as well as share it with others. You can read about it here:

All times are GMT -5. The time now is 06:55 AM.