Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 02-16-2004, 02:29 AM   #1
Registered: Dec 2003
Location: Petaling Jaya
Distribution: Ubuntu
Posts: 475

Rep: Reputation: 31
sound card, kernel 2.6

I have never this issue with my 2.4.x kernel. With my new kernel, 2.6.2, everytime I boot into my Linux, the volume is 0. So if I want to enjoy the sound, I have to turn the volume up with XMMS, or Kmix. So how can I solve this problem?
Old 02-16-2004, 05:06 AM   #2
LQ Newbie
Registered: Dec 2003
Distribution: Gentoo
Posts: 25

Rep: Reputation: 15
The 'quick and dirty' solution is to add two lines to your startup scripts:
amixer sset Master 20 unmute >/dev/null
amixer sset PCM 20 unmute >/dev/null
On my sound card (nForce2 onboard), those two channels max at 31, so 20 is a reasonable value. Experiment a bit to find a pair of values that work nicely.

On my system, the relevant startup file is /etc/conf.d/local.start. I don't know where it is on Fedora, but try locate local.start and try any result that it turns up.
Old 02-16-2004, 06:40 AM   #3
Registered: Aug 2002
Location: Cape Town, South Africa
Distribution: Red Hat 8.0 (Home), Red Hat 8.0 (Work)
Posts: 388

Rep: Reputation: 30
In Fedora you should put these lines in /etc/rc.d/rc.local
Old 02-16-2004, 08:34 AM   #4
Registered: Dec 2003
Location: Petaling Jaya
Distribution: Ubuntu
Posts: 475

Original Poster
Rep: Reputation: 31
Talking It works

Ok, thank you, guys. It works. I have to downloaded alsa-drivers, alsa-utils, alsa-tools first so that I have amixer command. Now I have fun with my new kernel, 2.6.2, though why I got this problem is still mistery for me.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't use sound card after kernel rebuild vin7 Linux - Hardware 0 01-17-2005 11:22 AM
Sound card for kernel 2.4.20 on sun V60z ekedmo Linux - Hardware 1 08-15-2004 06:10 PM
sound card not visible from the kernel humanrig Linux - Hardware 2 03-15-2004 07:45 AM
Sound Card not found in new 2.6.0 kernel ckamheng Slackware 15 12-24-2003 05:27 AM
my new kernel can't locate the sound card coldy Debian 5 11-23-2003 10:46 AM > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 10:33 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration