LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Somehow I broke the splashimage with GRUB 0.95 on RHEL4 (https://www.linuxquestions.org/questions/linux-general-1/somehow-i-broke-the-splashimage-with-grub-0-95-on-rhel4-486186/)

kevman 09-23-2006 12:45 AM

Somehow I broke the splashimage with GRUB 0.95 on RHEL4
 
I was playing with the splashimage and made one in GIMP, I actually made a few sucessfully but now none seem to work. Here is the obligatory grub.conf :
Code:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,1)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/hda
splashimage (hd0,1)/grub/splash.xpm

default=0
timeout=20


title Red Hat Enterprise Linux ES (2.6.9-34.EL)
        root (hd0,1)
        kernel /vmlinuz-2.6.9-34.EL ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.9-34.EL.img
title Windows
        rootnoverify (hd0,0)
        chainloader +1

Now the symptom (which i have heard of once before (through googling) but with no solution) i'm having is that it when grub loads, it shows a blinking _ for 20 secs (my timeout, during this time i can press enter) and then it loads linux with what appears to be a corrupted vga font? A grid of dots appear and some characters look garbled. When init decides to load a font then it is fixed, and everything works (just a bootloader prob.). When i take out the splashimage command from da .conf file then it shows the menu no problem, and there are no funny dots or weird characters, but also no pretty pic!

By da way, yes it is a 14 color xpm that i have tried gzipped and plain.

Thanks.

FreeDoughnut 09-23-2006 03:46 PM

Have you tried one that's proven to work? Maybe something got messed up.

kevman 09-23-2006 05:19 PM

Yes, I have. That's why i think that i have messed something up but can't figure out what.


All times are GMT -5. The time now is 03:40 AM.