-   Linux - General (
-   -   Solved: VLC running under root without compiling (

Net_Spy 08-17-2009 12:33 PM

Solved: VLC running under root without compiling
Greetings to All,
I've searched the forum for my issue but could not find any satisfied answer , this is solution is for whom who did yum or apt-get to install vlc player.

Step-1: open a hexeditor if you are using kde desktop then use khex editor .

Step-2: Now open vlc binary

Step-3: Now search for the following string geteuid which is look like this


Since I'm usuing version 0.9.9a-2 so I found it online numbers 1550-1560 .

Step-3: Now press insert button from keyboard and change string into


Step-4: click on Save

If it is duplicate thread im sorry for repeating but im sure it is not hope it works for you too , as it works for me. still make u annoy when you run vlc from console it gives you same warning but when u run it back it works fine :).


Quakeboy02 08-17-2009 01:52 PM

If you need to run VLC under root, you have some more fundamental problem that you didn't (or won't) address.

iamsrijon 10-22-2009 12:06 PM

Great Job
you ve done a great job, dude. I am here to appreciate u for the help on Running vlc player as root without compiling.

Thanks again,

uray 08-30-2010 06:22 AM

great job, thanks, i uninstalled vlc just because of this issue, now it solved.

mindlessmissy 12-01-2010 07:42 PM

OMG, I just had to register to express my gratitude to the starter of this thread ...

I had been looking for a way to run the latest vlc under root on my mac for a long time now and this simple solution did it ...

Merci !

John VV 12-01-2010 08:22 PM

why VLC should never be ran as root
i take it you also run firefox as root
and have turned off the firewall and turned off SElinux or AppArmor
and have NOT installed firefox's no-script not installed add block plus

and LIKE to run a rootkited system

mindlessmissy 12-01-2010 11:02 PM

Unless vlc will make a gun protrude from my monitor and hold it against my head, I think I will be just fine ...

Thank You for Caring ...

monemihir 02-10-2011 09:47 PM

I am running vlc 1.1.4 and for me there was no instance like - ddset.stderr.geteuid._libc_start_man

However, as long as you replace all instances of "geteuid" with "getppid" you should be fine.

Thanks Net_Spy mate...ive been banging me head on this one for a long time !!!

John VV 02-10-2011 10:06 PM

as long as this thread is labeled as

-- WARNING , Not recommended ,do not use at your own risk --
-- example of a very bad system administration ---

and the public service announcement ( psa)
we do NOT care / give a bleep about YOUR computers .
It is all the OTHER computers on the net that we DO CARE ABOUT,that YOU are putting at risk

mmasic 02-26-2011 01:26 PM

Thank you - great job/solution!

mo0n_sniper 04-17-2011 01:06 AM

Nice, thanks man.
Now I don't have to login with a user without privileges to look at movies.

thefinn 10-25-2011 02:04 PM

nice pickup.

You sir are the man.

Net_Spy 04-11-2013 11:48 PM


An other method is below :

vi /usr/bin/vlc

search for geteuid and replace it with getppid

Save file & Exit.


All times are GMT -5. The time now is 09:51 PM.