-   Linux - General (
-   -   Slackware 9.0 installation - can't fdisk (

xlinuxSlayer 09-25-2003 02:53 AM

Slackware 9.0 installation - can't fdisk
I'm trying to install Slackware 9.0. I'm a total linux noob but I know how to read the installation tutorial. I can boot off the cd and log in as root. I used a win 98 boot disk to format a spare hard drive. First I set the whole drive as the primary partition. When I got to setting up the linux partions the linux fdisk said it was only a 695 meg hard drive but it's a 10 gig western digital hard drive. It said it wasn't a dos partition. So i read the installtion notes again and it said to use dos fdisk to create a small dos partition and leave the rest for linux. So i tried again and used dos fdisk to create a 500 meg dos partition and left the rest of the drive untouched. But when I got to the linux fdisk it still said i had a 695 meg hard drive and it wasn't a dos partition. I can only use fdisk in a read-only state. I cannot write any partition changes.

I hope my question makes sense. I cannot continue with the rest of the installation if I don't create a primary linux partition and a linux swapfile partition.

Is there a better way to set up my hard drive?

By the way, I have to use the ibmmca.s kernal at the boot prompt.

Nezzo 09-25-2003 09:49 AM

boot with the Slackware disk and use cfdisk instead of fdisk. If your not concered with any of the data on the disk don't worry about creating dos partitions.

just use cfdisk and remove all partitions and create a Linux partition (primary) and a Linux swap partition (logical). Give the Linux primary partition the boot option. Make the swap partition double the size of your ram (unless you got a G+ of ram). That's a good start for noobies :)

That's what i did when i first started.

xlinuxSlayer 09-25-2003 05:05 PM

Thanks I figured it out. The problem was that cfdisk was pointing to my cd rom drive, that's why it was 695 megs and read only. Slackware is running great now.

All times are GMT -5. The time now is 04:19 AM.