-   Linux - General (
-   -   Slack 10.1 -- Mouse issue / X11 issue (

Pozican 04-19-2005 12:01 AM

Slack 10.1 -- Mouse issue / X11 issue (Resolved)
alright, so I can't get the mouse to work in kde....

Not cool -- so I changed it from /dev/mouse to /dev/psaux...

didn't work

Then I changed the gpm(?) to use /dev/psaux instead of /dev/mouse and the mouse worked in bash....

so then I went into my .xinitrc and took out startkde....

NOW i'm getting an x error


_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/colby:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

The above was the top most error....

This next error was at the very bottom, but I bet it was a direct result of the top one eh?


Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!

Any help?

thanks guys,

Bruce Hill 04-19-2005 12:16 AM

What type of mouse do you have, and where is it located?

From a terminal issue
$ dmesg | grep -i mouse
and post the output.

And since it doesn't work in KDE, and you've got that in a mess,
perhaps you can boot and run
$ xwmconfig
and choose Fluxbox. That will help eliminate the KDE problems
until you get your mouse working. Also, you shouldn't change
gdm ... if you can, change it back.

Pozican 04-19-2005 12:52 AM

ok, so I got a response from cat on both /dev/mouse AND /dev/psaux -- X -configure decided on mouse, and when I changed it to psaux it worked in gnome....

Still doesn't work in kde -- go figure

dmesg | grep -i mouse produced nothing ( good I suppose )

Got any ideas for the kde junk?


Pozican 04-19-2005 12:55 AM

/me slaps forehead

wireless mouse batteries slow

sorry guys!

lol, my bad, i feel like an idiot

it was a pebkac error this whole time :(


Bruce Hill 04-19-2005 03:44 AM


Originally posted by Pozican

Got any ideas for the kde junk?



All times are GMT -5. The time now is 12:19 PM.