LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 12-19-2017, 11:36 AM   #1
lesibet
LQ Newbie
 
Registered: Dec 2017
Posts: 2

Rep: Reputation: Disabled
Angry SIP and Qt/PyQt errors on GNS3


Hi Guys,

can you please help, getting below error, when starting GNS3 version 2.1 on my debian machine. both packages installed.

Fail update installation: No module named 'sip'
Can't import Qt modules: Qt and/or PyQt is probably not installed correctly...


can you please help, thanks in-advance.
 
Old 12-19-2017, 04:41 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2018 CentOS6.10 CentOS7.5 + 50+ other Linux OS, for test only.
Posts: 17,105

Rep: Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489
Welcome to LQ.

Example, Debian 9 Stretch - amd64 : No issues. The gns3 GUI opens OK.

I added two lines to /etc/apt/sources.list :
deb <URL> stretch contrib
deb <URL> stretch non-free

... And did # apt update && apt install gns3

? Which Debian version is it about ? ?

-
 
Old 12-27-2017, 05:37 AM   #3
lesibet
LQ Newbie
 
Registered: Dec 2017
Posts: 2

Original Poster
Rep: Reputation: Disabled
Hi knudfl,

can you please share your source-list file, please.
Still getting same error.
 
Old 12-27-2017, 07:02 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2018 CentOS6.10 CentOS7.5 + 50+ other Linux OS, for test only.
Posts: 17,105

Rep: Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489Reputation: 3489
?
Which Debian version are you using ? ?
The example used in post #2 is Debian 9 Stretch - amd64.

Share a source-list ? I guess you mean ``sources.list´´ :
Debian <any Debian version> has /etc/apt/sources.list


-
 
  


Reply

Tags
gns3


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] PyQt broken after sip-4.16.9 upgrade marrowsuck Slackware 8 08-16-2015 08:29 AM
I am having trouble installing PyQt on Fedora 20 (it is needed for GNS3) troldahl Linux - Newbie 4 10-05-2014 05:01 PM
[SOLVED] gns3 message: Can't import Qt modules, PyQt is probably not installed saavedra29 Slackware 3 03-14-2012 11:40 AM
Getting lots of errors when compiling sip from source. What do they mean? BillWho? Linux - Newbie 6 05-04-2006 08:13 AM
pykde ,sip and pyqt question ngan_yine Linux - Software 0 01-31-2004 03:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 12:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration