LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 07-19-2001, 11:01 AM   #1
Stephanie
LQ Addict
 
Registered: May 2001
Location: Arizona
Distribution: 9.2 Mandy 1.4 Gentoo 5.1 FreeBSD WinXP
Posts: 1,166

Rep: Reputation: 45
Shell bypass to graphical environment


When my MDK 8.0 system boots up, it displays a command line first, then it switches to a graphical login. Now I like graphical logins, but how do I make it so that it does not display a command prom first, and just starts X immediately?
 
Old 07-19-2001, 11:32 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 194Reputation: 194
It pretty much does that on all distro's I have seen. It flashes really quickly the command prompt like your gonna login from there, then it goes and then starts X. Its just the way I guess it starts up.
 
Old 07-19-2001, 11:48 AM   #3
Stephanie
LQ Addict
 
Registered: May 2001
Location: Arizona
Distribution: 9.2 Mandy 1.4 Gentoo 5.1 FreeBSD WinXP
Posts: 1,166

Original Poster
Rep: Reputation: 45
Do you know of a way around this?
 
Old 09-03-2004, 11:11 AM   #4
Doom666
LQ Newbie
 
Registered: Sep 2004
Location: Australia
Distribution: Debian
Posts: 3

Rep: Reputation: 0
Oh, that's easy fixed... install Windows! Next you'll get a Mac and complain the Terminal is included.
But seriously, if you can't deal with the fact there are terminals and unix goings-on that your desktop runs on top of, why use unix?
 
Old 09-03-2004, 12:06 PM   #5
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 194Reputation: 194
Quote:
Originally posted by Doom666
Oh, that's easy fixed... install Windows! Next you'll get a Mac and complain the Terminal is included.
But seriously, if you can't deal with the fact there are terminals and unix goings-on that your desktop runs on top of, why use unix?
You do realize that this thread is almost 3 years old.
Secondly you should at least give an insightful answer instead of being a smartass about it. This is a legit question which just never got a full answer and I do know Stephanie realizes that her desktop runs on top of of a command line, etc.

One of the rules we like here.. post constructively or don't post at all.
 
Old 09-05-2004, 12:35 PM   #6
Doom666
LQ Newbie
 
Registered: Sep 2004
Location: Australia
Distribution: Debian
Posts: 3

Rep: Reputation: 0
Yes I realise it's an old post, but I was googling for something more useful. Then again I should've noticed the fact this is a site for questions as well their answers. I'm cranky what can I say.
Ok, in case it's ever useful...

init (the first process to be run once the kernel is loaded) is responsible for the startup of each of the vt's (virtual terminals).
It can be instructed to start fewer or even no vt's at all, by altering the file /etc/inittab. I personally don't recommend having no vt's however, because if X (the graphical environment) doesn't start, there's no way of logging in to fix the problem, other than telnet or ssh from another machine (and if that's also broken...?) But if you really want them all gone, don't let me stop you.

Anyway, here's an example, an excerpt from the /etc/inittab on my girlfriend's computer which only has one vt, as she has no use for them, and it's a rather old system (every little bit helps).
Each of these lines represents the allocation (startup) of a vt. They are usually listed in order of appearance, but a line ending with tty1 represents the first, tty2 the second and so on. Commenting out a line (putting a '#' before it) will disable that vt. This is preferable to deleting the line, so it can be easily restored if needed.

Code:
1:2345:respawn:/sbin/getty 38400 tty1
#2:23:respawn:/sbin/getty 38400 tty2
#3:23:respawn:/sbin/getty 38400 tty3
#4:23:respawn:/sbin/getty 38400 tty4
#5:23:respawn:/sbin/getty 38400 tty5
#6:23:respawn:/sbin/getty 38400 tty6
 
Old 09-05-2004, 12:56 PM   #7
Doom666
LQ Newbie
 
Registered: Sep 2004
Location: Australia
Distribution: Debian
Posts: 3

Rep: Reputation: 0
I should also mention that changing the number of vt's doesn't alter the vt X appears on (it's also considered a vt), or the key combination for switching to it.
This is controlled by the script that starts X (note this is not startx). In Debian, this is the file /etc/X11/xinit/xserverrc. You want the vtN option.

For example, on my system that has four vt's, and X on the fifth (Ctrl-Alt-F5), my xserverrc looks like this:
Code:
#!/bin/sh
exec /usr/bin/X11/X vt5 -dpi 75 -nolisten tcp $*
PS, I'm a smartarse? Why thankyou, it's nice to be appreciated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphical environment doesn't load anymore xstealthrtx Linux - Newbie 3 11-23-2004 12:06 PM
graphical environment not working mouse46 Mandriva 11 08-09-2004 08:33 AM
Will my Graphical ENvironment not start automatticly? fedivh Slackware 19 08-08-2004 03:09 PM
Graphical Desktop Environment Gerardoj Linux - General 3 10-30-2003 07:00 PM
can't log in graphical environment abd_bela Debian 3 09-12-2003 07:43 AM


All times are GMT -5. The time now is 04:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration