LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-14-2004, 01:18 PM   #1
ShadyCharacter
LQ Newbie
 
Registered: Jan 2004
Distribution: Fedora C1
Posts: 6

Rep: Reputation: 0
Setting correct permissions for my ~/


I decided a little bit ago to move my /home dir to it's own separate Reiser partition, because it was getting pretty large and using up my smallish / partition.
Everything seemed to go smoothly, and I chown-ed and chmod-ed the user dirs (I think) correctly.

I tried starting openoffice, but when I do that I get
bash: ./soffice: /bin/sh: bad interpreter: Permission denied
I thought 'hmm..' and then tried starting NWN. Well...
bash: ./nwmain: Permission denied

I retried setting permissions, but to no avail.

Here's what I did as root...
Code:
chown -R <user> /home/<user>
chmod -R 754 /home/<user>
And if it helps, here's my /etc/fstab line for the partition.
Code:
dev/hda6               /home       reiserfs            auto,rw,user,owner           0 0
 
Old 04-14-2004, 02:52 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914
Well, those messages suggest that you've
chmod'ed (or moved?) something other than
/home ...


Cheers,
Tink
 
Old 04-14-2004, 11:06 PM   #3
arrruken
Member
 
Registered: Apr 2003
Distribution: gentoo
Posts: 238

Rep: Reputation: 32
Re: Setting correct permissions for my ~/

Here's what I did as root...
Code:
chown -R <user> /home/<user>
chmod -R 754 /home/<user>

do a "chgrp <group>(most likely users) /home/<user>"
And if it helps, here's my /etc/fstab line for the partition.
Code:
dev/hda6               /home       reiserfs            auto,rw,user,owner           0 0
[/QUOTE] [/B]

and set "user" to "users", I believe you have to specify a user when using user, whereas users lets anyone mount it, although you dont need to considering it is automounted at boot time.

Last edited by arrruken; 04-14-2004 at 11:08 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
automounting fat32 drive with correct permissions johannlo Linux - General 1 07-05-2005 08:37 PM
Vsftpd changes file permissions....how to correct? 88guy Linux - Software 1 05-25-2004 05:17 PM
What are the correct permissions for /etc? KingofBLASH Slackware 1 01-31-2004 08:56 PM
How to set correct file/directory permissions pat.delaney Linux - Networking 5 12-02-2003 09:39 AM
giving apache the correct permissions dflorence Linux - Newbie 3 11-06-2003 08:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 04:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration