LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Serial terminal connected to USB Serial Port on Ubuntu 12.04 (https://www.linuxquestions.org/questions/linux-general-1/serial-terminal-connected-to-usb-serial-port-on-ubuntu-12-04-a-4175469615/)

809areacode 07-14-2013 03:01 PM

Serial terminal connected to USB Serial Port on Ubuntu 12.04
 
Hello,

I am trying to get a serial terminal to work with my Ubuntu 12.04 computer. I was able to get text displayed and log in, but it isn't displaying correctly. Here is how I have it set up:

exec /sbin/agetty -L 9600 ttyUSB0 vt100

I have a Wyse 60 on the other end, configured to emulate a vt100.

When I type a command that gives a lot of output, instead of scrolling up, it continues from the top, for example:

ls -la

Will produce

root@host$
----- output here
------
-----
----

If the output is particularly long, the prompt might reappear in the middle of the screen.

Any ideas?

tronayne 07-15-2013 09:23 AM

There is a group of terminal capabilities entries in (/etc/termcap.BSD) for Wyse 60 models that you might want to try (those are Wyse 60 native mode entries). Probably do better with those than with the vt100 emulator entries. They're also in /usr/share/terminfo files.

I used to have a bunch of those (nice terminal!), but I had to roll-my-own termcap/terminfo for them (we're talking the 1980's here on UNIX systems). I do remember that you must use XON/XOFF with them and don't try to run them above 9600 Baud. I still have a Wyse 99-GT (the one that switches into Tektronix mode) floating around somewhere (I think it's in storage about 200 miles from here).

Might want to try using native mode and see what you get -- you can also try vt220 and see if that'll work for you (I seem to remember that it did, but we're talking the dim and distant past so I can't be sure). But you do need to enable XON/XOFF or hardware control so you don't overflow it -- it'll only 9600 Baud.

Don't forget to export TERM=wyse60.

Hope this helps some.

jefro 07-15-2013 04:28 PM

http://www.tldp.org/HOWTO/Text-Terminal-HOWTO-10.html

809areacode 07-18-2013 11:06 PM

Works fine on Debian. Rather than scratch my head over this one I think I'll just jump to Debian.

In case anyone else wants to get one working on Debian, here are the settings I used:

getty 9600 8/1 no parity vt100

And on the terminal vt100 personality.

Thanks anyway, guys.


All times are GMT -5. The time now is 10:07 AM.