LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Sendmail /etc/mail/virtusertable not created (https://www.linuxquestions.org/questions/linux-general-1/sendmail-etc-mail-virtusertable-not-created-39385/)

katana 12-26-2002 02:46 AM

Sendmail /etc/mail/virtusertable not created
 
Hi everybody,
I'm using Sun Enterprise 250 machine, installed with Solaris 8. Recently I downloaded the latest version of sendmail (which is sendmail-8.12.6 ) , and compiled it with this command:

./Build NROFF=nroff MANDOC= install

This ran without a problem. Then i edited my host.mc (which is web.mc ) file like so:

divert(0)dnl
VERSIONID(`$Id: web.mc,v 8.13 2001/06/27 21:46:30 gshapiro Exp $')
OSTYPE(solaris2)dnl
DOMAIN(generic)dnl
FEATURE(virtusertable, 'dbm /etc/mail/virtusertable')dnl
MAILER(local)dnl
MAILER(smtp)dnl


Then I ran ./Build web.mc

This also ran without a hitch. Then I went about following the steps in this how-to:

www.sendmail.org/virtual-hosting.html

Evertyhing was ok, or so I thought. But when I ran this command:


makemap /etc/mail/virtusertable < virtusertable.txt

I found out that the /etc/mail/virtualusertable file was not created! Hmm..funny. The virtusertable.txt file is where i put in my virtual user table (since I plan to do virtual hosting). But I fear because of the nonexistent /etc/mail/virtusertable, it wouldnt work. I was right. When I ran this command to test it:

sendmail -bt

Then I typed in this command:

> /map virtuser suzana@ict.com.my

I got this error message:

dbm map "virtuser": missing map file /etc/mail/virtusertable''
map_lookup: virtuser (suzana@ict.com.my) no match (75)

What's the problem? I think I've followed the instruction quite clearly ( the keyword is ' i think' ;) )...i dont understand. How come my /etc/mail/virtusertable is not created? Even when I created it manually, i still got the same error..

help..headache :(

suzana

peter_robb 12-28-2002 01:07 PM

Are you running makemap from the same directory as your virtuser.txt file?

waffe 10-02-2003 04:30 PM

Hi katana,

I have the same problem. I have just installed sendamil on a debian box and I can't seem to find/make a virtusertable. Did you ever solve your problem. If so, how did you do it.

Thanks,

Bill

cvanbrederode 03-01-2004 11:54 AM

I'm having a similar problem on _both_ my Red Hat 9.0 boxes. When I run makemap hash file > file on either box, the process hangs. No activity from the process in top, but it can be killed and/or Ctrl-C'd out. Don't think it would take more than a blink to makemap a two line file with a 2.6 GHz P-4 w/ HT :(

Anybody else running into this problem?

Chris Van Brederode
http://www.intlogsys.com

waffe 03-01-2004 01:19 PM

Been A while
 
Sorry but I probably can't help much because I brought a guy in to fix my server problems. Sometimes it is just easer that way.

Have you had mail working at all, ever? Or is this a fresh install of red hat?

I had just installed a new version of Debian when I learned that I had to put all server mail components together manually. Like qpopper, sendmail mail, berkly db. Pain in the ass I tell ya!

Bill


All times are GMT -5. The time now is 04:25 AM.