-   Linux - General (
-   -   Segmentation fault (core dumped) (

plisken 09-16-2003 02:19 AM

Segmentation fault (core dumped)
I keep getting a Segmentation fault, when running certain commands, like ncftpget.

This worked fine for long enough, but as of today, I get this error.

Any ideas?



yapp 09-16-2003 06:47 AM

Did you install/upgrade some existing software? or is there something wrong with a library the program uses?

If a lot of programs start to crash, you might need to check your hardware. such as your memory, or an overheated CPU. ....or in the worst case, is your machine rooted/hacked?

a "segmentation fault" is an classical programmer's error; the application tries to access an invalid (unassigned) piece of memory. Fortunately, Linux is able to trap those attempts, which would otherwise cause your system to become instable.. :)

A segmentation fault might happen aswell when a program doesn't know what to do in a certain situation. (and the programming didn't handle that situation) ...technically speaking; the program tries access memory-address 0, because a calculation didn't succeed. (or a calculation failed because of an hardware problem)

plisken 09-16-2003 10:18 AM

Hmm, havent changed anything, noticed that when I rebooted though, that there were many errors picked up by fsck, which has been the case for months, but as the machine hardly gets rebooted, it has not caused too much concern.

Possibly time to start backing up, before things go pear shaped?

I also notice that I get a lot of busy inodes on changed media messages, if that means anything to you.

plisken 09-16-2003 11:24 AM

Managed to trace it to mail, whenever anything tries to use mail, I get this error.

Tried resinstalling sendmail and also but the problem remains, any ideas?

plisken 09-16-2003 11:37 AM

When I verify the package, I get the following error:

sendmail -:/etc/aliases md5, file size, modification time

I also got a group error, but sorted that by changing it from root to mail.

Any ideas?

yapp 09-16-2003 12:33 PM

I'm not sure what sendmail has to do with it, except for the fact why you're running sendmail...? Sendmail isn't required to "send mail". It's a mail server; ie. mail-transfer-agent (that's why it's called sendmail). You can configure your e-mail program (mail agent) to either send a message to the SMTP server of your ISP, or let sendmail deliver it for you directly.

You don't need to run it, unless you want a personal mail server, and I would certainly advice against allowing connections from the internet to sendmail if this is just your workstation. :rolleyes:

Just curious: did you run fsck (or e2fsck) in single user mode (or at boot time), and was your root-partition was mounted read-only? A lot of missing inodes might also be a problem for linux. (making it crash randomly)

What file system are you using? If you use ext2, you might want to upgrade to ext3, which can recover your data if your machine went down. (fortunately, this doesn't happen if your machine is always on :p)

---hope this helps

yapp 09-16-2003 12:39 PM


Originally posted by plisken
Managed to trace it to mail, whenever anything tries to use mail, I get this error.
I'm curious what your approach was to tackle this problem..

..but I don't understand how ncftp is involved into this, then.

plisken 09-17-2003 03:10 AM

Sorry for the confusion...

Basically I have a few cron jobs that run, a couple of which contained "ncftp", then mail the details to me.
Now initially, instead of getting mailed the output from the cron jobs as per normal, I simply got Segmentation messages e-mailed to my accounts. At this point I naturaly suspected the problem to be with ncftp, and it was not until later, when trying to e-mail from the console, using mail, that I got the same error.

I normally send all my mail through my server, and for that matter collect much of it from different accounts, by use of fetchmail, then simply connect using Outlook to retrieve. It saves me from connecting to a bunch of different accounts, fetchmail gathers it all and I collect it all together.


Removed sendmail and reinstalled, reconfigured my file and still had the same problem, Segmentation Error, when ever I tried to use the command "mail"

But, I done another reboot, and all would now appear to be fine.

You did mention fsck, I did do an fsck on the previous reboot, and there were a number of errors, this is normal every 3rd or 4th time I reboot, but as I try and keep the machine running, it has not posed too much of a problem.

I am running ext2 and have in the past been advised to move to reiser or similar.

Comments are, as always, appreciated...


yapp 09-17-2003 03:32 AM

you're description is quite helpful to understand your situation.

I still can't explain your segfauls (I'm not that kind of an expert), except for all the things I mentioned above. But there are some other things that might be usefull too:

*'re using sendmail, because fetchmail needs to devliver your e-mail to an SMTP server? Is the smtp-server reachable from the Internet too? / does it have to be?

* If you're receiving mail from a lot of different accounts (like I do too), I'd suggest installing an IMAP server locally. Unlike POP3, imap keeps all folders, sent/received messages and stuff like 'read status' at the server. so, it doesn't matter what mail-client you'd use, because you'll see the same e-mail in every client. (or even webmail) outlook express supports imap as well.

* I'm not so sure how to convert ext2 to reiser, but converting to ext3 is quite simple:
  • is ext3 supported by your kernel?
    grep ext /proc/filesystems
  • go to single user mode
    telinit 1
  • remount your root partition read-only:
    mount -o remount,ro /
  • to be sure, force a check your file system:
    e2fsck -f /dev/hd...
  • add an ext3 journal to your file system:
    tune2fs -j /dev/hd....
  • remount read-write
    mount -o remount,rw /
    I'm not sure whether mount -ext3 -o remount,rw / works :rolleyes:
  • Update your /etc/fstab, change the 'ext2' field into 'ext3'
  • back to the previous runlevel (or just enter reboot):
    telinit 5 (or whatever the level was)
    The command runlevel shows the current and previous runlevel

good luck :)

..edit: if your filesystem gets corrupted in everyday work, you might need to "untweak" the harddrive parameters/settings. (use the hdparam tool with great caution) Setting these values too high is asking for trouble ;)

All times are GMT -5. The time now is 12:33 PM.