-   Linux - General (
-   -   Scsi Emulation!! (

FearPasion710 09-19-2003 08:41 PM

Scsi Emulation!!
Hi and thank you everyone for you time!

well to the point........i did my first ever kernel compile yesturday and to my surprise it worked!!! :D Everything work's the way i spected to work i removed thing that werent needed by my system and the system itself has become more responsive... my boot times are even faster.... Kde is faster etc.........

well im using Slackware 9.0 by the way.. i installed or compiled
k3b the cd burning software on my computer and stuff and it told me i needed to enable scsi-emulationg for my burner in order to work.. and i did and it worked... had to recompile my kernel for that too.. but it worked with no probs......

The thing is that i also have a DVD-Rom drive that i wanted to use for copiying cds. Ex...put the cd to be copied on the dvd-rom and let the burnere read off the dvd-rom drive...

but i cant cuz of this...

No support for ATAPI with cdrdao
You will not be able to use all your reading devices as copy sources since there is at least one not configured to use SCSI emulation and your system does not support ATAPI with cdrdao.
Solution: The best and recommended solution is to enable ide-scsi (SCSI emulation) for all writer devices. This way you won't have any problems.

does anyone know how to do this...

i did the same excat things i did for my burner.. but it still does not work.

my lilo.conf set is this..

append="hdd=ide-scsi" <---being my Cdr-rw
append="hdc=ide-scsi" <---being my Dvd-rom

my fstab looks like this..

/dev/hda5 swap swap defaults 0 0
/dev/hda1 / reiserfs defaults 1 1
/dev/hdb1 /mnt/Media reiserfs defaults 1 1
/dev/scd1 /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/scd0 /mnt/cdrom2 iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

ps... /dev/scd1 <---DVD-ROM
/dev/scd0 <--Cdr-RW

Any ideas.....??


contrasutra 09-19-2003 09:24 PM

recompile cdrdao with ATAPI support. check the ./configure --help for the exact flag.

FearPasion710 09-19-2003 09:55 PM

But i al ready figured it out! Thanks

Thank you all for ur help!

Shade 09-20-2003 04:14 AM

How did you figure it out?

When you figure something out here, it's kind to post your solution -- so that others with the same problem will have their answer from a search :)


All times are GMT -5. The time now is 11:11 AM.