-   Linux - General (
-   -   Screen goes blank after being idle 4 a long time & then all input devices freeze! (

hari_seldon99 01-28-2004 08:16 PM

Screen goes blank after being idle 4 a long time & then all input devices freeze!
( post #1)

I'm running Linux mdk 9.2 on a gateway 310X. Now, whenever I leave my machine idle for extended periods of time (like 4+ hours), I return to find that the monitor is blank (though it's not in power saving mode) and moving the mouse or keyboard does not bring the screen back. I have to reboot (ctrl-alt-del) and then it shows the shutdown process (where it fails to shutdown the saslauth daemon) and reboots. At first, I thought that apm was suspending the machine and messing it up (apm has been known to do that, I understand), so I got rid of it, but the problem persisted. I looked at /var/log/security and saw that it ran "msec" a lot when idle so I disabled that as well. The problem still persists.

Can anybody tell me which log files I should see to diagnose what's happening. Once I know what's causing this, I can try to fix it.

Thanks in advance,


moxfyre 01-28-2004 09:38 PM

Does this happen only when you're running X? Or does it happen if you're logged in at a console? Can you get to another virtual console by pressing ctrl-alt-F1?

Well... if you're running GNOME, check your Screensaver Preferences and disable "Display Power Management" (in the Advanced tab). I don't think your input devices are actually freezing, because, as you said, you can escape by pressing ctrl-alt-delete.

I've had problems with X blanking the screen and refusing to do anything before. If you can pin it down as a Display Power Management problem, then you should check your X log: /var/log/XFree86.0.log.

Hope this helps!


hari_seldon99 01-29-2004 02:48 AM

This happens when XFree86 is running, yes. I tried to goto the console when the screen froze by pressing ctrl-alt-F2, but no luck.

I have been running KDE., where I've not only disabled power management, but set the uid bit of /usr/bin/apm so that my nonroot id can't even access it. Still the damn thing freezes.

I'll check /var/log/XFree86.0.log, thanks.


hari_seldon99 01-29-2004 04:58 AM

It happened again! I rebooted and looked at /var/log/XFree86.0.log.old. It's too big to incluse here. I've posted it on

. Note the last line that says

Fatal Server error:

So I guess the X-server is doing something bad...

In line 1877 it does something to the mouse or the ps2 port/driver or whatever, then it says :

Error in I830WaitLpRing(), now is 4888, start is 2887

The rest of it is Sanskrit ...

Do peruse and assist!

moxfyre 01-29-2004 10:30 AM

Hmm... I notice from your XFree86.0.log that DPMS (display power management) is still being enabled when you start X.

It looks like you are using the i810 video driver. Try using just the plain VESA driver for a bit and see if the problem stops. Edit your /etc/X11/XF86Config-4 file, and look for

Driver "i810"

Try changing it to Driver "vesa", restart X, and see if the problem recurs. It may be a problem with the particular video driver you're using.

hari_seldon99 01-29-2004 05:22 PM


Yeah, that worked. No more blanks, but now I have another problem.

Whenever I try to play a video in mplayer, I get the following error:

Error opening/initializing the selected video_out (-vo) device.

No problems in xine or totem. They work as before. Could this problem be related to the fact that I changed the video driver for X as you instructed? How to I tell mplayer to setect the driver correctly?


hari_seldon99 01-31-2004 02:35 AM

I'm having additional problems.....

1> mplayer will not go to fullscreen mode anymore after I switched the driver to "VESA"

2> When I boot into Linux, the X Server starts up just fine. When I log off, instead of showing the login screen, the screen blanks out. When I shut down, the screen no longer shows the usual status messages (stopping this daemon, that daemon etc) but blanks out altogethrer until the machine shuts down. It then restarts OK.

These problems did not exist when I was using the i1810 driver, but then my X-Server suggered "fatal crashes" after extended periods of inactivity.

Are there any other drivers I should try? Should I reinstall the i1810 thingie from an rpm from somewhere or from source?

Please do offer suggestions. I'm utterly lost

moxfyre 02-02-2004 07:40 PM

Sorry for not getting back sooner. No net access at home for the weekend =(. I'm not sure about mplayer. It sounds like you have a buggy i810 driver (or maybe your hardware is not well tested with the driver, whatever) and the VESA driver isn't fully functional.

Do you know if your kernel is running with framebuffer support or not? The fact that running X messes up the text console suggests that this might be a framebuffer problem...

hari_seldon99 02-02-2004 08:57 PM

Yeah, I think it is running in framebuffer mode.

So should I verify about that by booting in linux-nonfb and seeing if that works??

sikkalgopal 07-13-2005 12:21 AM

screen goes off after long time
hai all

I had the same problem , i investigated in log files nothing found,also done all changes in the power management options in BIOS as well as in OS.Then i enabled screen saver , now working
without trouble even for days.Anything relation to that. Clarification will be helpful.


hari_seldon99 07-13-2005 12:31 AM

Thx for reply. After 1.5 years, I've changed distros to fc3 after I saw how badly broken Mandriva has become and have put all that Mandrake nonsense behind me.

All times are GMT -5. The time now is 04:19 PM.