-   Linux - General (
-   -   scrambled display after entering "power saving?" state (

rbees 02-21-2008 08:11 AM

scrambled display after entering "power saving?" state
Ladies & Gentlemen.

I am sorry if this should be posted in a different fourm

I need some advice on where to look to find the cause of a scrambled display.

This is a clean install. However, this is one of the reasons for the clean install.

What happens / happened:

HP dv9000 laptop
most recent nvidia driver
Debian Testing (this weeks image) (was suppose to default to kde but I got gonome)

I had the typical nvidia setup issues and after I got the dependencies installed the driver installed and the gui came up.

However, when I shutdown the xserver I get a scrambled display. What I mean. Sometimes it is divided into 4 sections (I have 4 virtual displays) and I can see the two on the left, one over the other, and on the right side of the screen I can see a portion of the other two. At other times I have two columns displayed with blue vertical lines and on the left side of each there is a columns that I can tell is displaying the shutdown messages but they are very small (pencil eraser size).

This happened with the previous install too, after I reinstalled the nvidia driver so that I could use the gui with the ~.22-3 kernel.

I just logged out and tried to do a console login and got a bunch of blue vertical lines but I could not see the prompt.

The display also enters this corrupt state if the display is allowed to enter what i think is a low-power state. But I have not enabled the screensaver or power management in the display configuration. I had thought that it should not enter this 'low-power' state.

It does not do this if I boot to single user mode from grub.

So, how do I determined if this is a bug or some kind of config problem?

Where do I look first?

This is outside the scope of my past experience.

I did find a post that said the frame buffer will conflict with the nvidia drivers and to change the vga= option in grub but that option is not set in my menu.lst.

My son's machine that is also a fresh Debian testing (older cd) install has a similar problem, haven't actually watched it, he only told me about it. He is using an intel processor where I am amd, but we are both using the most recent nvidia graphics driver from there site (169 something). His is desktop, mine is laptop. He is i686-32, I am amd64.

Still searching but not seeing very much that relates.

Thanks to all.

rbees 02-21-2008 08:46 PM

More info:

When I ctrl+alt+f* I get the same vertical lines as I have after the display goes into whatever kind of power-saving mode it is going into. ctrl+alt+f7 brings me back to a correctly displayed desktop.

I set the vga=*** in grub's menu.lst to vga=771 and init 6. The vertical lines seem to be thinner and closer together maybe.

For what ever reason the xserver seams to be not releasing the display somehow.


rbees 02-26-2008 05:32 AM


I uninstalled the most recient driver from the Nvidia site and installed the older one (_100.14.90..) again. It seams that the the -169.09.. version doesn't play nice with my card.


All times are GMT -5. The time now is 07:16 PM.