-   Linux - General (
-   -   Savin prints junk then a dozen blank pages (

andguent 10-02-2003 11:46 AM

Savin prints junk then a dozen blank pages
Redhat 9 - trying to print directly to Savin 2545 (network standalone super printer) over TCP.

When I use the Gnome GUI helper through CUPS I can print to the JetDirected HP2100N and HP4050N just fine. The current W2k print server sends data RAW to port 9100 of the Savin, and that operates fine (as fine as W2k operates..).

When I send any print job direct to the Savin (RAW, PostScript, or Text only) on port 9100 I get a paper with 3 lines of text (each one tabbed over a little more then the previous) and then 12-24 blank pages. The thing prints at 45+ppm so its kind of a pain to cancel. The 3 lines look like chopped up code.

I managed to find a "unix installer" from Savin and ran that. It setup info in printcap.conf. No success there either. I went back and tried to reconnect using the Gnome GUI through CUPS to connect to the printer using LP (<printer-ip>/lp). No success. I tried using the GUI to connect through Samba to the W2k print server, and cannot connect to the print que. File shares on the same server I can connect to.

During each of these test setups, I have closely watched what config files the GUI tools are modifying. For the past week I have been trying all sorts of combinations manually. Unfortunately I am slowly running out of ideas.

Thanks in advance for any ideas, no matter how well they work. :)


andguent 10-10-2003 02:20 PM

Just a small bump to try again.

andguent 10-17-2003 01:52 PM

Big thanks to those at for trying to help. I did finally get this fixed.

I knew it had to be something simple. I opened up my Samba Server
administration book from the Craig Hunt library, and accidentally opened to the exact page I wanted (while trying to fix something else).

The 3 lines each shifted over a couple tabs is "caused by printers that expect DOS style end of line characters". The page before states that most laser printers emulate the HP laserjet 4/5/6 type printers. I set my driver to a 5si, and viola, working test page. I doubt it will be easy to get it to staple, punch, or duplex, but it works. I guess I should have mentioned that my printer had PCL emulation. Oops.

I highly recommend these maroon Craig Hunt Linux Library books.


All times are GMT -5. The time now is 02:20 PM.