-   Linux - General (
-   -   samba and fstab not playing nice (

kc8tbe 03-05-2003 05:26 PM

samba and fstab not playing nice
I have a samba server and client sucessfully up and running on my machine. The following command mounts a share from a winxp machine:
mount -t smbfs -o password=p // /mnt/winxp
Don't be fooled, though, the following command fails, reporting that the share name is invalid:
mount -t smbfs -o password=p // /mnt/winxp
While as root I can mount and unmount the filesystem whenever I want, other users can't. And the following entry in fstab also causes the invalid share name error:
// /mnt/winxp smbfs password=p,user 0 0
Variations such as removing the "user" argument and adding a "/" to the end of "...Docs" have no effect. I suspect fstab is automatically appending a "/" to the end of the mount command when it runs, and I seem to be powerless to stop it.
Any idea how I can get this to work?

nxny 03-05-2003 07:07 PM

what is the username? Are you logging in as guest?

How about suid permissions on the mount binaries?

ls -l /bin/mount /usr/bin/smbmnt

chmod 4755 to turn them to suid.

kc8tbe 03-06-2003 05:24 PM

The file smbmnt already existed. I ran ran chmod on smbmnt and mount (I couldn't use the option -l or -I - they produced "invalid option" errors). Still no success on mounting the samba filesystem on bootup. Not even by adding the mount command to rc.local.

The filesystem CAN be mounted after login - but only when I log in as root. I can then logout, login as a normal user, and still access the filesystem - until I reboot.

What else can I try?

nxny 03-07-2003 03:13 PM

The -l ( the letter 'ell') options wasnt for the chmod. It was for ls, that lists options in the 'long' format.

What does your fstab contain?

All times are GMT -5. The time now is 06:59 PM.