LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 12-26-2005, 02:09 PM   #1
anjanesh
Member
 
Registered: Sep 2004
Location: Navi Mumbai
Distribution: Ubuntu 14.04 64-bit
Posts: 230

Rep: Reputation: 30
Running newaliases


Hi

Im currently on WinXP OS and my webhost server is using Linux-FC4 for which I have root access but only know how to copy-paste files.

I was looking through evolt's article on how to capture incoming mails in PHP.

I had to add a line in etc/aliases file.
But in the aliases file its mentioned The program "newaliases" must be run after this file is updated for any changes to show through to sendmail.
I've only uploaded the modified aliases file to my server.

How do I run "newaliases" ?

Im using WinSCP 3.7.6 .

Thanks
 
Old 12-26-2005, 02:55 PM   #2
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
Type "newaliases" in a shell and press enter...
If you have root access, then what's the trouble?
Can you not get a shell on the Fedora box?
 
Old 12-26-2005, 06:33 PM   #3
WindowBreaker
Member
 
Registered: Oct 2005
Distribution: Slackware
Posts: 228

Rep: Reputation: 40
anjanesh:
Run the following command:
newaliases /etc/aliases
 
Old 12-26-2005, 09:52 PM   #4
anjanesh
Member
 
Registered: Sep 2004
Location: Navi Mumbai
Distribution: Ubuntu 14.04 64-bit
Posts: 230

Original Poster
Rep: Reputation: 30
Ok. I ran but "Open Terminal" in WinSCP and entered the command newaliases but returns command not found - failed with error code 127.

I understand this is the same as sendmail -bi but when I entered this command in WinSCP command terminal, I get the msg
Failed with return code 100.
sendmail: usage: sendmail [ -t ] [ -fsender ] [ -Fname ] [ -bp ] [ -bs ] [ arg ... ]
Any idea what I should be entering ?
 
Old 12-26-2005, 10:48 PM   #5
WindowBreaker
Member
 
Registered: Oct 2005
Distribution: Slackware
Posts: 228

Rep: Reputation: 40
Did you run the command while logged in as root?
make sure you are logged in as root and do:
which newaliases
should show you the path to the newaliases command.

If it doesn't, maybe you did an 'su' as root but retained the regular user's PATH setting, so check /sbin, /usr/sbin, etc.
Or just use the find or locate command.
 
Old 12-27-2005, 12:45 AM   #6
anjanesh
Member
 
Registered: Sep 2004
Location: Navi Mumbai
Distribution: Ubuntu 14.04 64-bit
Posts: 230

Original Poster
Rep: Reputation: 30
Yes - I logged in as root in WinSCP and went to root (/) directory.
Opened terminal in WinSCP am entering the commands.

WindowBreaker - I entered what you gave. I got this.
Code:
/$ which newaliases
which: no newaliases in (//sbin://bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin)
 
Old 12-27-2005, 11:27 PM   #7
anjanesh
Member
 
Registered: Sep 2004
Location: Navi Mumbai
Distribution: Ubuntu 14.04 64-bit
Posts: 230

Original Poster
Rep: Reputation: 30
Apparently the server is using Qmail and not Sendmail !
Because it was mentioned The program "newaliases" must be run after this file is updated for any changes to show through to sendmail. in the aliases file I assumed the server had Sendmail.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix : newaliases peoblem zamri Linux - Networking 13 09-14-2005 03:48 AM
newaliases problem kafnir Linux - Networking 1 07-11-2004 01:52 AM
newaliases problem kafnir Linux - Networking 1 06-24-2004 03:13 PM
Postfix's newaliases-command not working ZeiP Linux - Software 1 03-22-2004 03:04 PM
Problem using "newaliases" to update sendmail alias file davidks1977 Linux - Software 4 03-17-2004 11:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 04:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration