-   Linux - General (
-   -   running low on the home partition (

DirkvdM 07-19-2007 04:47 AM

running low on the home partition
Sorry about the long story, but I want to be as complete as possible because I haven't a clue what's going on.
Yesterday, I just got a message that the system (Suse 10.2) was getting critically full. Part of the cause was probably that I just copied some sizeable directories to a newly installed hd. KDirStat gave a critical clue; out of the 10GB for the system (the partition on which it is mounted), 40% (3.38 GB) was taken up by both /usr and /z/S500_7_ext3_FOTOS (partition 7 on the new hd, a SataII 500GB). I keep system and data completely separated, with all partitions mounted under /z/ (so it's conveniently listed at the bottom in Konqueror).
The odd thing is that those two (/usr and /z/S500_7) were both 3.38 GB, but I saw no overlap in the files. Is this just a huge coincidence? All the other drives mounted under /z/ showed as empty (well, a few kB). I believe I had mounted S500 'by hand', so I added it to fstab.
When I booted again today, the system was again full (or rather 'running low on the home partition', which I never use). At least, that's what Konqueror said, and when I looked at the properties in / it said only 50 MB free, but only 92 MB used in the home partition. But KDirStat showed less than 6 GB out of 10 GBused. So I compared the values given by both and apart from some 'minor' differences, Konqueror said /proc was 2 GB in size, while KDirStat said it was almost empty. I told KDirStat to delete trash files on /proc, after which it showed it as 4 TB (4096 GB) in size, which is a whole lot more than my total hd space (which is just over 1 TB). And Konqueror even said it's 256 TB in size. The offending file was /proc/files/kcore.
So I rebooted, which solved that problem, but I've still got only 50 MB for the system. KDirStat says only 5.09 GB used, of which 3.38 GB by /usr, and 0 Bytes for /proc, for which Konqueror gives 2.0 GB. But even all the sizes shown by Konqueror add up to only about 7.5 GB, while the partition has a size of 10 GB. So why does Konqueror say my system running low on space? Oh, and 'df -lh' shows for the root partition (sda7) Size 9.9 GB, Used 9.4 GB and Avail 45 MB (which doesn't add up either).
Btw, I've had this before and found that 'home/dirk/thumbnails' was 'overfilled' (due to many image-downloads, I imagine), but that's not it this time.

syg00 07-19-2007 07:01 AM

Forget /proc - it's a pseudo filesystem for exposing kernel structures.
Doesn't really exist, and certainly doesn't occupy disk space.

Let's see the output of "du -hT" from a terminal.

jschiwal 07-19-2007 07:34 AM

Are the /home & /usr directories mounted on their own partitions. If the /home directory isn't on it's own partition, then a different directory on the same partition may be growing causing the available space on /home to shrink. This isn't necessarily bad, because it would be easy to make a mistake what the /usr partition would need in 6 months time. If you underestimate it, it will be fill up on you. If you overestimate it, you are using space that you could have used for /home or another partition on the drive.

You don't need to worry about the /z/* directories if they are mounted on their own partitions.

DirkvdM 07-19-2007 10:20 AM

du -hT doesn't work because --T is an invalid option. du -h gives
4.0K ./.qt
4.0K ./bin
4.0K ./.kde/share/servicetypes
4.0K ./.kde/share/applnk
4.0K ./.kde/share/apps/koffice
72K ./.kde/share/apps/konqsidebartng/filemanagement/entries
76K ./.kde/share/apps/konqsidebartng/filemanagement
80K ./.kde/share/apps/konqsidebartng
12K ./.kde/share/apps/konqueror
4.0K ./.kde/share/apps/kopete
4.0K ./.kde/share/apps/kfm/bookmarks
8.0K ./.kde/share/apps/kfm
28K ./.kde/share/apps/RecentDocuments
4.0K ./.kde/share/apps/khtml
44K ./.kde/share/apps/kconf_update/log
48K ./.kde/share/apps/kconf_update
192K ./.kde/share/apps
4.0K ./.kde/share/services
4.0K ./.kde/share/mimelnk
4.0K ./.kde/share/config/session
360K ./.kde/share/config
572K ./.kde/share
576K ./.kde
4.0K ./.mozilla
4.0K ./.fvwm
24K ./.wapi
16K ./.gnupg
20K ./.kbd
4.0K ./.thumbnails/large
8.0K ./.thumbnails
788K .
I have just mounted /home on a separate partition (20GB in size, so that should be plenty I'd say), with the help of (I made some mistakes, so I was glad to have a dual boot, so I could undo my misdoings). After that I ran du -h again, but the result is the same, except for 5 entries (.../RecentDocuments, .../apps, .KDE/share, .KDE and . ), wich are a few kB bigger.
Could mounting /usr elsewhere (on the same alternative partition?) solve the problem? Not that I have a clue why, though.
Overusing space is not really an issue, considering that I have over 1 TB of hd space.
Btw, I suddenly had the problem that neither Google nor Yahoo worked (opening websites worked, just not the search), but that was gone after a reboot. Weird, and I'm not sure if it is in any way related to the problem at hand.


I have just done the same with /usr that I did with /home (except all as root this time), copying the contents to another partition, renaming the old /usr (to /usr_old) and creating a symbolic link from /usr to the new location. And the system started, so, impatient as I am, I deleted the contents of /usr_old (except that /usr/include wouldn't go). Konqueror said it was removing over 5 GB, but now I've still only got 3.7 GB free disk space. I still don't get how things don't add up like that. However, if that won't decrease anymore now that /home and /usr are elsewhere (is that a correct assumption?) then I've got nothing to worry about. Right? (Fingers crossed for the next reboot.)

syg00 07-19-2007 08:03 PM

D'oh; sorry - that should have been "df -hT"

All times are GMT -5. The time now is 02:36 PM.