LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 07-12-2003, 05:51 PM   #1
c0c0deuz
Member
 
Registered: Aug 2001
Location: Qc, Canada
Distribution: RedHat, Mandrake, FreeEOS
Posts: 336

Rep: Reputation: 30
rpm: installed or not installed...


I am trying to install fetchmail on redhat 9

I download the rpm from redhat,
I lunched: rpm -Uvh fetchmail-version.rpm and it returns:
-package fetchmail.version is already installed

ok! so i try to remove it so i can reinstall it...
rpm -e fetchmail.version.rpm and it returns:
-error: package fetchmail.version.rpm is not installed

Euhm.... What is the matter, here!
 
Old 07-12-2003, 05:57 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 60
rpm -qa|grep -i fetchmail
to see if it is actually installed, and also you can try to
rpm --rebuilddb
and then try to remove it, if it is still there
don't matter what order you do this in, its just a couple of things you can try.
 
Old 07-12-2003, 06:14 PM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984
c0c0deuz, this is a bit basic for you isn't it? did you also try searching the site?

http://www.linuxquestions.org/questi...threadid=50059
http://www.linuxquestions.org/questi...threadid=70324
http://www.linuxquestions.org/questi...threadid=65527
 
Old 07-12-2003, 06:15 PM   #4
c0c0deuz
Member
 
Registered: Aug 2001
Location: Qc, Canada
Distribution: RedHat, Mandrake, FreeEOS
Posts: 336

Original Poster
Rep: Reputation: 30
rpm -qa|grep -i fetchmail
return the fetchmail.version-no

rpm --rebuilddb
return an error:
error: db4 error(16) from dbenv->remove: Device or ressource busy
 
Old 07-12-2003, 06:38 PM   #5
c0c0deuz
Member
 
Registered: Aug 2001
Location: Qc, Canada
Distribution: RedHat, Mandrake, FreeEOS
Posts: 336

Original Poster
Rep: Reputation: 30
Nothing is basic anough for me acid...
Thanks, your last link give me the answer.
I was confusing packetage and file :^(
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RPM package manager says package needs to be installed. But I already installed it! nick623 Linux - Software 2 05-24-2005 02:15 AM
rpm -ivh says installed rpm -e says not installed ??? skog Fedora 3 12-22-2004 03:52 PM
RPM is saying installed packages aren't installed ticky87 Linux - Newbie 4 07-26-2004 01:17 AM
Already installed rpm js72 Fedora 2 03-22-2004 04:25 AM
RPM installed barDo Linux - General 3 10-27-2001 05:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 01:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration