LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 11-09-2003, 11:05 AM   #1
bestmehr
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Rep: Reputation: 0
RPM dependancies are met, but...


I have all the dependancies installed, but when I try to install enlightenment I get a message indicating that libImlib.so.1 is needed. I have /usr/lib/libImlib.so.11 and I also made a symlink libImlib.so.1 -> /usr/lib/libImlib.so.11.

I am having similar dependancy problems with other RPM installations where the needed file is present but the RPM installer cannot see it. When I try to install the required RPM, of course I get the message indicating that the file is already installed. Seems like the RPM DB is out of synch...


Any help is appreciated.
 
Old 11-09-2003, 04:54 PM   #2
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
not 100% sure this will work
but it won't hurt either way

su to root and type

/sbin/ldconfig

then try installing again
 
Old 11-09-2003, 05:32 PM   #3
randomblast
Member
 
Registered: Aug 2003
Location: Manchester, England, UK, The World....
Distribution: Gentoo/SuSE 9.0
Posts: 291

Rep: Reputation: 30
i had some libIMlib problems trying to install 3dfile, apparently it's part of gnome, i symlinked the header file and edited the Makefile to point to it but still it would not compile.
i didn't try anything else because i don't use file managers anyway, i was just bored.
 
Old 11-14-2003, 04:07 PM   #4
MaulingMonkey
Member
 
Registered: Aug 2003
Posts: 31

Rep: Reputation: 16
Re: RPM dependancies are met, but...

Quote:
Originally posted by bestmehr
I have all the dependancies installed, but when I try to install enlightenment I get a message indicating that libImlib.so.1 is needed. I have /usr/lib/libImlib.so.11 and I also made a symlink libImlib.so.1 -> /usr/lib/libImlib.so.11.

I am having similar dependancy problems with other RPM installations where the needed file is present but the RPM installer cannot see it. When I try to install the required RPM, of course I get the message indicating that the file is already installed. Seems like the RPM DB is out of synch...


Any help is appreciated.
I believe this tends to be caused by manually installing (aka not via RPM) the libraries in question. Although I don't know how to fix that, if you have the dependencies then you should be able to just force the install... something like:

rpm -i --force enlightenment.rpm

(too bad you can't force erasures if something depends on said package...)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Apt, RPM and Dependancies in Redhat 9 Rounan Linux - Software 9 04-13-2008 10:55 AM
RPM Circular Dependancies - Another Way? Kilo Linux - General 3 02-19-2004 12:35 PM
rpm says missing dependancies but I do have the files davoman Linux - Software 7 11-25-2003 07:16 AM
RPM dependancies james3mg Linux - Newbie 27 07-24-2003 03:57 AM
rpm dependancies j-charles Linux - Newbie 1 09-26-2001 12:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 12:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration