LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-18-2006, 03:18 AM   #1
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Rep: Reputation: 30
Root mounted read only


Hello,

I am trying to move my existing Ubuntu installation to another harddisk. However, after I tar it over the taget partition and boot it. The root partition is mounted read only.

Not sure if it would help, the source partition is EXT3 format on a parallel ATA harddisk, mount option is default. The target partition is REISERFS format on a SATA harddisk, mount option is notail noatime. I am runing Ubuntu 5.10.

It looks like I am missing something. Please advice what other information you would need.

Thank you.
 
Old 01-18-2006, 05:58 AM   #2
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,350

Rep: Reputation: 127Reputation: 127
Have a look in /boot/grub/grub.conf, maybe there's an option "ro" ?
 
Old 01-18-2006, 07:21 AM   #3
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Original Poster
Rep: Reputation: 30
I don't have /boot/grub/grub.conf but I have /boot/grub/menu.lst. I suppose they are the same.

Yup there is the ro option. However, this is the Ubuntu default setting and the original partition mounted fine with ro. Are you suggesting that I get rid of it?

Edit: btw, removing the ro option didn't help. In /etc/fstab the partion has errors=remount-ro option. What is preventing it to mount properly?

Last edited by Navyblue; 01-18-2006 at 07:38 AM.
 
Old 01-25-2006, 10:36 AM   #4
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Original Poster
Rep: Reputation: 30
Anyone?
 
Old 01-25-2006, 11:07 AM   #5
azucaro
Member
 
Registered: Jan 2005
Location: Washington, D.C.
Distribution: Arch (Custom), CentOS
Posts: 239

Rep: Reputation: 30
It sounds like it is a problem between the two filesystem formats. The errors=remount-ro means that it will attempt to mount rw and if there is problems it will reverts to ro. Obviously here 'mount' isn't able to mount the reiserfs filesystem on the partition. Are the fstab options correct? Let us know which partition you are coming from and which one you are going to, and give us the fstab listing please.
 
Old 01-25-2006, 01:12 PM   #6
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Original Poster
Rep: Reputation: 30
Thanks for the reply.

The target partition fstab line:
Code:
/dev/sda1 / reiserfs defaults,errors=remount-ro 0 1
Initially I used the notail noatime option, but changing it to defaults doesn't help.

The source partition fstab line:
Code:
/dev/hda1 /media/linux ext3 defaults,user,noauto 0 0
I recalled that I used to have a problem, not sure it might have anything to do with it. When installing Ubuntu on a parallel ATA drive, I can't get it to automount my SATA drive during booting, although I can mount it after the boot.

Last edited by Navyblue; 01-25-2006 at 01:14 PM.
 
Old 01-25-2006, 03:22 PM   #7
azucaro
Member
 
Registered: Jan 2005
Location: Washington, D.C.
Distribution: Arch (Custom), CentOS
Posts: 239

Rep: Reputation: 30
The fstab looks correct. Have you ran a fsck on it?

How did you partition and install the FS on the drive?
 
Old 01-25-2006, 08:39 PM   #8
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Original Poster
Rep: Reputation: 30
Hi,

Running "fsck /dev/sda1" while booting from hda1 while sda1 is unmounted gives me the followings:

Code:
###########
reiserfsck --check started at Thu Jan 26 09:33:20 2006
###########
Replaying journal..
Reiserfs journal '/dev/sda1' in blocks [18..8211]: 0 transactions replayed
Checking internal tree..finished
Comparing bitmaps..finished
Checking Semantic tree:
finished
No corruptions found
There are on the filesystem:
        Leaves 774
        Internal nodes 6
        Directories 1248
        Other files 17774
        Data block pointers 79213 (0 of them are zero)
        Safe links 0
###########
reiserfsck finished at Thu Jan 26 09:33:25 2006
###########
I'm not really sure how I did the partitioning and formatting. Either I used the Ubuntu installer or QTparted, both are frontends of parted I suppose.
 
Old 01-26-2006, 09:16 AM   #9
azucaro
Member
 
Registered: Jan 2005
Location: Washington, D.C.
Distribution: Arch (Custom), CentOS
Posts: 239

Rep: Reputation: 30
When it is being mounted read-only, is it listed as reiserfs? I believe 'mount -l' will give you that information. Also, I'm not sure if fstab lets you put 'auto' as the filesystem (like mount), but it is worth a try.

Beyond that, I'm not sure why this is happening here.
 
Old 01-28-2006, 06:22 PM   #10
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Original Poster
Rep: Reputation: 30
Sorry for the late reply. You probably nailed it. It is weird.

mount -l says nothing about sda1. It says hda1 is mounted as root, while fstab says the other way round.

When I try mounting sda1, it says hda1 is already mounted as root, so I can't mount two partition at the same place.

When I try to mount hda1, it mounted where it should be at (not root). And apparently hda1 is not mounted as you can't mount a mounted partition, while mount -l says otherwise.

Would it has anything to do with GRUB or the MBR? Sort of mixed up the partitions and thought sda1 was hda1?
 
Old 01-28-2006, 06:26 PM   #11
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Original Poster
Rep: Reputation: 30
Btw, this is my GRUB entry:

Code:
title		Ubuntu, kernel 2.6.12-10-k7
map		(hd2)	(hd0)
map		(hd0)	(hd2)
root		(hd2,0)
kernel		/boot/vmlinuz-2.6.12-10-k7 root=/dev/sda1 ro quiet splash
initrd		/boot/initrd.img-2.6.12-10-k7
savedefault
boot
I have hda, hdb and sda as harddisks. GRUB resides in MBR of hda.
 
Old 01-28-2006, 07:00 PM   #12
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Original Poster
Rep: Reputation: 30
I found my solution, it is probably silly. "errors=remount-ro" options only works for ext filesystem, not for reiserfs, so removing that solves the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cdrom Mounted but Non Root User Can't Read tortle Slackware 7 11-22-2005 06:33 AM
Oops- mounted root as read only! Hawklad Debian 4 04-26-2004 06:59 PM
root fs is mounted read only after adding new drive PPaladin Linux - Hardware 0 03-02-2004 11:25 AM
Mounted drives are read only for non-root edawad Linux - Newbie 1 01-11-2004 11:30 PM
root mounted as read only behmjose Linux - Newbie 1 12-17-2003 12:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 12:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration