LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 07-17-2002, 01:42 PM   #1
Ryan_Sutton
Member
 
Registered: May 2002
Location: California
Distribution: Fedora 9
Posts: 101

Rep: Reputation: 15
Roaring penguin - sbcglobal


Anyone use sbcglobal with roaring penguin to connect to the internet? I have tried for a week now to get RP to connect with my SBC DSL acount and have had no success, I tried many diff configurations and it attempts to connect however it times out. If someone knows of a fix for this please help.
 
Old 07-24-2002, 03:26 AM   #2
mrdensity
Member
 
Registered: Apr 2002
Location: Central US
Distribution: Libranet 1.9.1 & 2.0, tinyX (2dskxwin) & WinLinux 2001
Posts: 83

Rep: Reputation: 15
I found sbcglobal.net to need my full email address to connect. Not just the username.
type "adsl -setup" and basically follow the prompts.
I forget where their page is that lists their DNS servers but here are mine. The first is for the Wichita Ks area. The second is a fallback server. 151.164.70.201 and 151.164.70.8 , these should work for you also. If I can find the page that has them listed I will try to post the link here for you.
After it is configured you can type "adsl -start", pretty soon it should say ".......Connected !" to bring it down type "adsl -stop". (All commands are sans quotes).
If you intend to share the connection... dont forget to set the mtu on your other boxes to 1492. Use "ifconfig ethx mtu 1492" without the quotes and ethx being the card that connects your machine to the gateway/router.

Last edited by mrdensity; 07-24-2002 at 03:36 AM.
 
Old 07-24-2002, 02:37 PM   #3
Ryan_Sutton
Member
 
Registered: May 2002
Location: California
Distribution: Fedora 9
Posts: 101

Original Poster
Rep: Reputation: 15
thx I'll give that a try, as for the other boxes on my network I thought the best mtu would be 1412???
 
Old 07-24-2002, 03:35 PM   #4
mrdensity
Member
 
Registered: Apr 2002
Location: Central US
Distribution: Libranet 1.9.1 & 2.0, tinyX (2dskxwin) & WinLinux 2001
Posts: 83

Rep: Reputation: 15
I found 1492 to work best.
SORRY ! the correct command is "adsl-start" not "adsl -start". note the space in the incorrect command. The commands should point to the scripts in the /usr/sbin directory.
http://www.dslreports.com/tweaks has a set of bandwidth tweaks and references that helped me out. They mentioned in their tweaks that for PPPoE the mtu needs set to 1492. Make sure that java is enabled for the tests to work correctly.
If you want it to start at boot you can add a link to your /etc/rc5.d from the source /etc/init.d/adsl. I'm pretty certain it will need to be started after networking is running.
I hope this helped !

Last edited by mrdensity; 07-24-2002 at 03:40 PM.
 
Old 07-24-2002, 03:49 PM   #5
Ryan_Sutton
Member
 
Registered: May 2002
Location: California
Distribution: Fedora 9
Posts: 101

Original Poster
Rep: Reputation: 15
great, thx again for the help!
 
Old 07-24-2002, 11:09 PM   #6
mrdensity
Member
 
Registered: Apr 2002
Location: Central US
Distribution: Libranet 1.9.1 & 2.0, tinyX (2dskxwin) & WinLinux 2001
Posts: 83

Rep: Reputation: 15
Glad to help !

I hope that got things going for you.
You're Welcome .
 
Old 07-26-2002, 09:18 AM   #7
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Rep: Reputation: 45
in addition, since i have sbcglobal.net dsl working on my box...you need to enable all the PPPoE options in your kernel...which are usually by default not selected...meaning you may have to recompile your kernel...Otherwise Roaring penguine is never going to work. Second, the user name IS just your username, following in the DNS space sbcglobal.net
then type your password.
Thirdly, what modem are you using?? hope you didn't get the green USB dsl modem that looks like a fish... if you did however, I recommend, like I did, to call SBCglobal and ask them to change your modem for an Ethernet one. They changed mine in like 2 or 3 days...good thing it's all done through the mail,
and well anyway...let us know more.

zLinuxz
 
Old 07-26-2002, 06:48 PM   #8
Ryan_Sutton
Member
 
Registered: May 2002
Location: California
Distribution: Fedora 9
Posts: 101

Original Poster
Rep: Reputation: 15
I have an thernet. As far as the usernmae I have heard two people tell me its only "xxxx"@sbcglobal.net and I know of one person who had to use "xxxx@sbcglobal.net" I'm not sure we he need all that info to dial up, I have my DNS servers, as far as the kernel goes, what ver are you running? Im using Slacks 2.4.18 kernel and most people I've talked to havn't had to recompile to pppoe support, you're the first to mention it, what lines need to be added/uncommented? Thanks!
 
Old 07-26-2002, 09:22 PM   #9
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Rep: Reputation: 45
that could be then why it isn't working properly. Yes, I'm sure it is just the "xxxx"@sbcglobal.net which you should type in your user name. And well, check your kernel configuration and see if the PPPoE options are compiled into the kernel...otherwise there is NO PPPoE support, so how's RP going to work?..getting me?..other people maybe haven't said it cuz perhaps they overlooked it or just assummed you knew...but anyway try it and see what happens, good luck,
 
Old 03-30-2003, 01:30 PM   #10
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
I have SBCGlobal ADSL connection and I have to use my full email addresss as my username. I suppose it may vary by geographical area.

I am not too happy with the intermittent outages on my service. I know it's a network problem as I haven't changed a thing on my system. Some days it's always on, some days it's maddeningly prone to failure. I have to recycle the modem sometimes five or six times to get it working again.

I use Mandrake (started with 8.0, then 8.2, now 9.0). Setup was very, very easy and near automatic. Much easier than when I used Windows!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
roaring penguin Ryan_Sutton Linux - Networking 2 07-22-2002 04:20 PM
RH7.2 Roaring Penguin apparition Linux - Distributions 0 04-27-2002 01:18 PM
roaring penguin problem cerberus Linux - General 0 04-12-2002 12:52 AM
roaring penguin ... leprechaun Linux - General 7 02-06-2002 03:50 PM
Roaring Penguin Rules!! DavidPhillips Linux - General 0 10-04-2001 10:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 10:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration