-   Linux - General (
-   -   rm: cannot remove directory `ff': Directory not empty (

blancs 03-05-2005 05:58 PM

rm: cannot remove directory `ff': Directory not empty
Nothing I do will delete this dir, and it couldn't be anyome empty! what the ....?

acid_kewpie 03-05-2005 06:04 PM

there are no dot files in it? show use the output of "ls -la /that/direc/tory/"

Brian1 03-05-2005 06:05 PM

Have tried the following command ' rm -drf ff '. Requires root to do this operation.

" Google the Linux way @ "

blancs 03-05-2005 06:18 PM

here is a the 'ls -la output'
dhcp-17:ff # ls -la
total 8
drwxrwxrwx 1 root users 4096 Mar 5 18:07 .
drwxrwxrwx 3 root users 4096 Mar 5 18:07 ..

# rm -drf ff
rm: cannot remove directory `ff': Directory not empty

blancs 03-06-2005 02:02 PM


david_ross 03-06-2005 03:17 PM

What about rmdir?
rmdir ff

blancs 03-06-2005 03:46 PM

same output error

tredegar 03-07-2005 04:04 AM

Have you tried running fsck on that partition? Maybe the filesystem has errors.

You can reboot and force fsck to run as it reboots if you use shutdown -Fr in a console.

blancs 03-07-2005 10:23 AM

That was it, not sure why i didnt think about that... thanks tredegar

Cyhaxor 05-08-2008 01:46 PM


rm -R directoryname/*
and then
rm -R directoryname

Omer Fadul 05-08-2008 03:29 PM

also try: find . -name 'directoryname*' |xargms rm -fr

tredegar 05-08-2008 03:53 PM

@ Cyhaxor & Omer Fadul,
I don't know how you reached this thread, or why you thought you should post to it, but it was answered three YEARS ago.
It is DEAD and should be left to rest in peace.

SlowCoder 05-08-2008 06:20 PM


Originally Posted by tredegar (Post 3147382)
It is DEAD and should be left to rest in peace.

Go easy. I've accidentally posted to old threads, too. Generally due to a search I did on a subject, and didn't look at the last post date.

Omer Fadul 05-12-2008 01:28 AM

Dear tredegar
firstly, there is no rule stopping me to post to any threads on this site. beside i was facing the same problem a few weeks a go and i was unable to remove all the files on /var/log/clientmailqueue because i am not using sendmail or postfix services and all root emails was logged to that directory; the total number of files exceeded 635,981 files, the ususal rm -f did not work, and after alot of work i reach to that solution. all i was trying to add was to share my knowledge with others.

Sabastian.xu 06-03-2008 03:06 AM

i have the same problem
# rm -R Qtopia/*
rm: cannot remove `Qtopia/*': No such file or directory

# df -h Qtopia/
Filesystem Size Used Avail Use% Mounted on
/dev/sdb1 3.0G 69M 2.8G 3% /opt/Qtopia

U can try
# umount Qtopia/
# rm -rf Qtopia/

All times are GMT -5. The time now is 12:27 PM.