LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-16-2003, 05:45 PM   #1
billkris
LQ Newbie
 
Registered: Jan 2003
Location: Burlington, ON Canada
Distribution: RH8
Posts: 26

Rep: Reputation: 15
RH9 theme problem


My desktop layout just went screwy. All my default icons changed to the same thing. I was just reading email and have not installed anything today.

When I try to start theme manager I get this error:

The default theme schemas could not be found on. This means that you probably don't have metacity installed, or that your gconf is configured incorrectly.

I am running rh9, gnome with the default bluecurve theme.

Can anyone tell me how to fix this mess.
 
Old 04-17-2003, 09:35 PM   #2
billkris
LQ Newbie
 
Registered: Jan 2003
Location: Burlington, ON Canada
Distribution: RH8
Posts: 26

Original Poster
Rep: Reputation: 15
I have reinstalled metacity and the themes and theme manager. It didn't make a difference.

Is there a default gconf I can install to at least put gnome back to its default settings?
 
Old 07-10-2003, 06:09 PM   #3
zippytheclown
LQ Newbie
 
Registered: Jul 2003
Location: Texas
Distribution: RH 8.0 & 9.0
Posts: 7

Rep: Reputation: 0
I am going through the same thing. It just kind of happened. Have you had any luck resolving it?
 
Old 07-10-2003, 06:32 PM   #4
nanobrain
LQ Newbie
 
Registered: Jun 2003
Location: MD
Distribution: RH 9
Posts: 3

Rep: Reputation: 0
The same thing happened to me too: between upgrading control center and gconf to their latest versions some of the gconf entries went MIA. I am a myself so I reinstalled both programs apparently in the right order, because it now works. The other thing I noticed is that the schemas were now installed in /usr/etc/gconf, while I believe un RH they are found in /etc/gconf. I symlinked /etc/gconf yo /usr/etc/gconf, maybe that's what soved it. MAybe one of the guru's can shed some more light on it.
 
Old 07-23-2003, 08:31 AM   #5
the scarecrow
LQ Newbie
 
Registered: Jul 2003
Location: Liverpool, UK.
Distribution: RH9
Posts: 6

Rep: Reputation: 0
Noobie Help needed

Hi, I have the same thing, I noticed it just after install, I went to change some setting (perhaps the theme itself, I forget), I got an error and blam, all my icons are the same, folders, files, etc. The metacity error comes up.

Metacity is installed (from RPM), but I am not sure what I need to change in gconf that will get it functioning? Or where it needs to be?

Current path is:
/etc/gconf

I want to do a symlink to 'usr/etc/gconf' but I am a week old Linux baby so I am not sure how its done, i'm off to google but any direct help would be much appreciated.

Cheers.

Last edited by the scarecrow; 07-23-2003 at 08:36 AM.
 
Old 07-24-2003, 04:54 PM   #6
zippytheclown
LQ Newbie
 
Registered: Jul 2003
Location: Texas
Distribution: RH 8.0 & 9.0
Posts: 7

Rep: Reputation: 0
I fixed my desktop using the gconf configuration editor (graphic interface) by putting the statement "Bluecurve" (without quotes)in /desktop/gnome/interface/icon_theme. That fixed the broken icons instantly. It has not fixed the general theme problems, and I still get the same type of metacity and schema errors when trying to use the theme manager. I have not found an answer to that one yet, but am still looking.
 
Old 07-28-2003, 10:55 PM   #7
patw
LQ Newbie
 
Registered: Jul 2003
Posts: 1

Rep: Reputation: 0
I had the same problems. It happened after I did some upgrades and also tried to install a SMB network printer. The printer installation failed. Anyway, I found a lot of values in gconf were reset to <no value>. I used gconf-editor and copy the values from a working RH9 system to fix the icon problem. The theme problem was fixed by looking for %gconf.xml.bak files in the /etc/gconf directory. Copying those files back to %gconf.xml in the same directory.
 
Old 07-29-2003, 07:09 AM   #8
BorgKiller
Member
 
Registered: Dec 2002
Location: Cyberspace, address block 212
Distribution: FreeBSD 6.1-RELEASE
Posts: 34

Rep: Reputation: 15
I have been having some very big problems with GNOME (Tool bar down the bottom doesnt load, errors left right and center) so i changed to KDE. I am using Redhat 7.3, but I am upgrading to redhat 9 soon.
 
Old 08-07-2003, 05:41 AM   #9
dragonreborn
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
Thumbs up

This worked for me...

create a shell script with the following in it (this is only three lines):

-----------snip---------

for i in /etc/gconf/schemas/* ; do
GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` gconftool-2 --makefile-install-rule $i > /dev/null
done

--------endsnip---------

What this does is reset the schemas to the default.

--------newbie section------

to create this script follow these steps:

-use your favourite editor to insert the above snip contents in a file and then save (as a 'good practice' rule name scripts with a .sh at the end).
-then use the following command to make the script an executable
$chmod 755 schemareset.sh

then become root and run the script.

-------end newbie section--------

I hope this helps you guys
 
Old 08-07-2003, 05:41 AM   #10
dragonreborn
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
Thumbs up

This worked for me...

create a shell script with the following in it (this is only three lines):

-----------snip---------

for i in /etc/gconf/schemas/* ; do
GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` gconftool-2 --makefile-install-rule $i > /dev/null
done

--------endsnip---------

What this does is reset the schemas to the default.

--------newbie section------

to create this script follow these steps:

-use your favourite editor to insert the above snip contents in a file and then save (as a 'good practice' rule name scripts with a .sh at the end).
-then use the following command to make the script an executable
$chmod 755 schemareset.sh

then become root and run the script.

-------end newbie section--------

I hope this helps you guys
 
Old 08-07-2003, 09:25 AM   #11
zippytheclown
LQ Newbie
 
Registered: Jul 2003
Location: Texas
Distribution: RH 8.0 & 9.0
Posts: 7

Rep: Reputation: 0
Before I try your script, what distribution are you running?
 
Old 08-07-2003, 09:33 AM   #12
zippytheclown
LQ Newbie
 
Registered: Jul 2003
Location: Texas
Distribution: RH 8.0 & 9.0
Posts: 7

Rep: Reputation: 0
What brought you to this solution? How did your original schema get damaged? I have NEVER touched my schemes and still had the failure. Sorry for all the questions, I would rather know the "why" before I blindly apply a fix...
 
Old 08-08-2003, 06:42 PM   #13
dragonreborn
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
distro: redhat 9 kernal 2.4.20-8 gnome 2.2.0

I actually had the problem as described by some of the guys above. I then stupidly changed the schema and did not take note what the settings were before i changed it.

I then researched into restoring the schema and this is what I came up with after a bit of research.

I found that fixed all the problems...luckily :-)
 
Old 08-11-2003, 12:57 PM   #14
zippytheclown
LQ Newbie
 
Registered: Jul 2003
Location: Texas
Distribution: RH 8.0 & 9.0
Posts: 7

Rep: Reputation: 0
The script worked. Very odd, I still wonder what caused the original modification though. Good fix, what resources did you use to research the schema restoration? For my own future reference...
 
Old 08-14-2003, 11:52 PM   #15
usj
LQ Newbie
 
Registered: Aug 2003
Posts: 2

Rep: Reputation: 0
RH9 theme problem

I am having exactly the same problem.
When I try to run the script posted
I get this message
" MUST SET THE GCONF_CONFIG_SOURCE"

please please HELP
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
for the life of me i cannot add a theme in theme manager ickselglic Linux - Newbie 5 03-13-2004 02:39 PM
Problem getting installed GNOME theme to show in theme list on RedHat 9.0 linux-fan64 Linux - Newbie 1 02-25-2004 06:16 PM
RH9 graphical login theme is corrupt cremeglace Red Hat 2 02-22-2004 09:05 PM
Theme Problem looper Linux - General 4 08-04-2003 09:19 PM
RH9 Theme installer not working... LinuxBAH Linux - Newbie 0 06-28-2003 02:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 08:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration