-   Linux - General (
-   -   Resized LVM, but ReiserFS wouldn't resize (

Polymorf 05-05-2007 11:49 AM

Resized LVM, but ReiserFS wouldn't resize
I have LVM set up on two discs running RAID 1 (sw) and ReiserFS.
I have resized my logical volume /home with

# lvresize -L +20G /dev/system/home-volume
but when I tried resizing the file system :

# resize_reiserfs -f /dev/mapper/system-home--volume
resize_reiserfs 3.6.19 (2003

reiserfs_open: the reiserfs superblock cannot be found on /dev/mapper/system-home--volume.

I have run this both with /home mounted and unmounted, and from runlevel 1,3,5 with the same result.

I have tried google without result. Some suggestions are reiserfsck --rebuild-sb but these were not mentioned in context with LVM, so I'm wondering if this would work ? I'm afraid of loosing data by trying the rebuild because I'm not sure what it does exactly.

Any suggestions?

MensaWater 05-05-2007 06:00 PM

You seem to have a typo somewhere.

You have "-home" at the end of LV on original command but "--home" in your reiser resize command. The output of the command also has the "--home" so I'm thinking this may be as simple as a typo in your reiser resize command. (That is to say remove the "--home" and make it just "-home").

Also the message complains about Reiser superblock missing. Are you sure it is a Reiser filesystems?

Polymorf 05-06-2007 08:21 AM

The double hyphen is correct actually.
However I made a huge blunder. I have previously used ReiserFS, but when I reinstalled maybe 6 months ago I chose ext3 and had forgotten about it. Embarrassing...
But now the problem is solved at least.
Thanks :D

All times are GMT -5. The time now is 06:49 PM.