-   Linux - General (
-   -   Renumbered Partitions->kernel Panic No Init... (

azornoz 04-29-2003 05:53 PM

Renumbered Partitions->kernel Panic No Init...
Facts: hda1 ntfs primary
hda5 ntfs (logical in ext.)
hda6 fat "
hda7 fat "

I removed hda6 to install linux (partitions renumbered):
hda1 ntfs
hda5 ntfs
hda6 fat
hda7 ext3 (/) mdk
hda8 swap
hda9 ext3 (home) mdk

Then I removed hda6 (fat) to install another linux flavour (partitions renumbered again-normal):
hda1 ntfs
hda5 ntfs
hda6 ext3 (/) mdk
hda7 swap
hda8 ext3 (home) mdk
hda9 ext3 (all in one) rh

Now after chaging menu.lst with the proper changes in kernel and root I got: INIT NOT FOUND, TRY PASS INIT= OPTION TO KERNEL when trying to boot mdk.
Now I know there is internal reference to the partition numbers where the system was.

Could please anybody tell me if there is a easy way to fix it up?
thanks, never happened before.

jailbait 04-29-2003 08:33 PM

When you move partitions around (or renumber them) you have to change you bootloader (either lilo or grub) to tell it where / is now located. You also have to change /etc/fstab to tell where all of the partition mountpoints are.

azornoz 04-30-2003 05:30 AM

Thanks for replaying.
I've updated fstab:
before after
/ hda7 hda6
home hda9 hda8
var hd10 hda9
swap hda8 hda7

I updated menu.lst :
kernel (hd0,5)/boot/vmlinuz root=/dev/hda8 init=/dev/hda6 mount=devfs acpi=off vga=788
initrd (hd0,5)/boot/initrd.img

Still getting these errors:
pivotroot: pivot_root(/sysroot, /sysroot/initrd) failed: 2
Remounting devfs at correct place if necessary
kernel panic: No init found.try passing init= option to kernel

If I try booting without initrd.img (I hate initrd.img always comment this line) get these ones:

Instead of pivotroot:
mount-devfs-fs():unable to mount devfs, err=-2
warnig: unable to open an initial console
kernel panic: no init ...

I appended init=/dev/hda6 to no avail like kernel options.
If I mount the partitions from the other linux everything seems fine.
thanks for your help.
Can I do anything more to fix it up?
why newbie people like me never think the right way?
I've read fstab hundreds of times just because I like to mount devices from command line (I do not like supermount or automount or ...)

azornoz 04-30-2003 06:11 AM

ok everything fine now.

In menu.lst there was an error ( mine of course). The kernel option root must say the root / and this is hda6 not hda8 that is /home.
Change the root option and linux is working ok.
thanks a lot jailbait (song of ted nuget, isn't it).

All times are GMT -5. The time now is 09:26 PM.