LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Redhat 8.0 + Kg7 RAID HELP!!! (https://www.linuxquestions.org/questions/linux-general-1/redhat-8-0-kg7-raid-help-36658/)

TomGerman 11-27-2002 07:07 PM

Redhat 8.0 + Kg7 RAID HELP!!!
 
First off let me say that I'm a linux newbie, so bear with me here.

I have a pretty nice system set up, which was originally using win2kpro:

Abit Kg7 RAID, athlon 1.47ghz
highpoint controller 370 on board
512 crucial ddr
geforce 4ti4600
2 maxtor 20gig ata 133 7200rpm drives

After becoming interested in linux, I decided to reformat the entire lot and give redhat 8 a try. When going through the install process I notice that Redhat doesn't recognize 1 large drive, but instead the 2 drives (doesn't see that it's RAID'd), even though in my bios the RAID array is working properly. I went through with the install regardless and got things running nicely (despite some problems with the NVIDIA drivers which I got sorted out eventually), but I'd like to reinstall everything and get RAID working. I checked out Highpoint's site about the RAID but I didn't really understand it. My ultimate goal would be to dual boot Windows 2kpro and redhat 8 with RAID 0.

I would greatly appreciate any help, as I would really like to leave M$ behind mostly, or at least dual boot the thing.

Thanks:)

-Tom

DavidPhillips 11-27-2002 08:34 PM

you will need to use the highpoint solution at their website

what problem did you have with it?

TomGerman 11-27-2002 08:44 PM

Well, first of there is no linux driver listed for 8.0.. secondly, if I install raid driver after I install linux.. how will that in any way help me? If I already have it installed I can't very well change the partitioning scheme to include both drives.. I dunno it's rather confusing to me :(

TomGerman 11-27-2002 09:01 PM

Also, there's a warning at the top of the page

"
WARNING:

The BIOS updates posted on this site are only suitable for use with PCI card Host Adapters, not motherboard/HPT3xx chipset combinations. Please visit the motherboard manufacturer's website for the proper download.

"

I have mother/hpt3 chipset combo, not PCI card... so I'm totally lost :(

DavidPhillips 11-27-2002 09:27 PM

I have a board with the highpoint chip and I used the kernel from the website anyway and it works.


I decided not to use it though, it was a lot slower than software raid

TomGerman 11-28-2002 12:11 AM

I'd like to use the one from the site, but since I'm a total newbie I don't understand the instructions :confused: ... what I'd like to do is have it so when I do a fresh install, I can load the drivers and it'll find that I have RAID. See, after I have linux installed, updating RAID drivers is useless to me as the partitions will be wrong... please someone help !

DavidPhillips 11-28-2002 01:27 AM

that's what you will need to do, you cannot install without the utilities from the site.

TomGerman 11-28-2002 04:38 AM

Umm... ? This has to be the least helpful website I've seen in my life. I ask a question, and say what I'm trying to do, then you repeat what I say. Lol

DavidPhillips 11-28-2002 04:48 AM

sorry but you need that utility, I could not get mine to install any other way

There is no magic words to type in for this problem

DavidPhillips 11-28-2002 04:48 AM

the question I had was what is the problem your having with it.

TomGerman 11-28-2002 05:55 AM

Ok, so I got the "utility"..."hpt3xx-opensource-v13.tgz" I did the instructions like the readme said, except for the part where it says to remove support for HPT366 because I didn't know how to do that, so I went ahead and built the driver and I got an error (error 1). when I did a modprobe nothing happened and when I tried to load the driver it failed and said it didn't exist. Not sure what I'm doing wrong.



here's what I'm using to make the driver

#make /usr/src/linux-2.4.18-14/=/usr/src/linux-2.4.18-14 RH80=1 ATHLON=1

and here's the last part of the insanely long output.. mostly filled with warnings

hpt.c:40: storage size of `hpt_notifier' isn't known
hpt.c:473: warning: `hpt_scsi_unregister_module' defined but not used
make: *** [hpt.o] Error 1


:newbie: lol...


DavidPhillips 11-28-2002 11:17 AM

The part about removing support is critical for this to work.

What happened is the driver comes built in but it does not work, so you must disable it and then the modprobe will work. It's in the config under the raid devices.

One thing you could do to solve the problem about needing to install it to the raid array if you have the equipment...

Install to a drive on one of the hda -hdd interfaces. Rebuild the kernel and get it working where it can access and use the raid array. Then move the system over to it.


I used RedHat 7.3 on mine. I got the array working and tried it before moving the entire system to it. It was really slow compared to software raid.

Something like 19 MB/sec if I remember correctly, software raid gets in the upper 60's like 68 or 69

TomGerman 11-28-2002 04:23 PM

I reinstalled and am now on software RAID. How do I check how many mbs/sec I'm getting? Which utility can I use?

DavidPhillips 11-28-2002 04:37 PM

hdparm -tT /dev/md0

DavidPhillips 11-28-2002 04:39 PM

you can test each drive alone too to see if one is slower

hdparm -tT /dev/hda

hdparm -tT /dev/hdb


All times are GMT -5. The time now is 07:48 AM.