LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Red Hat: Can't mount external hard drives anymore. Was rebooted without unmounting (https://www.linuxquestions.org/questions/linux-general-1/red-hat-cant-mount-external-hard-drives-anymore-was-rebooted-without-unmounting-632764/)

jwhitman 04-03-2008 01:14 PM

Red Hat: Can't mount external hard drives anymore. Was rebooted without unmounting
 
I have a red hat machine that will no longer detect external hard drives. It never had an icon for an external drive popping up on the desktop, but if I mounted a drive from the command line (after using the hardware browser to check where it was), it worked fine. Now, external drives still show up under /dev when I use the hardware browser, but I can no longer mount drives from the command line. I get the following error message:

sh-2.05b# mount /dev/sdc USB500
mount: you must specify the filesystem type
sh-2.05b# mount -t fat32 /dev/sdc USB500
mount: fs type fat32 not supported by kernel

When I was away, someone told me that the machine froze and had to be rebooted, so I suspect the problem resulted from an external drive not being unmounted properly before the machine was rebooted.

Any suggestions on how I can fix this?

Thanks

pljvaldez 04-03-2008 01:29 PM

The file type should be -t vfat, not "fat32".

jwhitman 04-07-2008 04:26 PM

Quote:

Originally Posted by pljvaldez (Post 3109730)
The file type should be -t vfat, not "fat32".

Thanks, but I still get the same error if I specify it as vfat:

sh-2.05b# mount -t vfat /dev/sdc USB500
mount: wrong fs type, bad option, bad superblock on /dev/sdc,
or too many mounted file systems

It's specified as fat32 rather than vfat on the hardware browser. Any other suggestions?

syg00 04-07-2008 05:41 PM

You mount partitions, not devices - try something like /dev/sdc1

jschiwal 04-07-2008 05:57 PM

You should use -t vfat as suggested and use the device node for the partition rather than the entire disk.

As for the automounting problem, are you booting with NOACPI by any chance. The dbusd and hald daemons require ACPI.
That could be the cause of the underlying problem.

Also for external drives, if you add an entry in /etc/fstab, don't use the device node (eg /dev/sdc1) in the /etc/fstab entry. Instead use the filesystems label or UUID number. If you know what the device node is presently, then run "udevinfo -q env -n /dev/sdc1". (I'm using /dev/sdc1 as an example) and the use "UUID=<the_fs_uuid>" or "LABEL=<the_disk_label>" in /etc/fstab. The reason for doing this is that you don't know if a device will have the same device node the next time it is plugged in. Using the "noauto" option is a good idea as well.
That will prevent the failure to mount a removable drive at boot time from causing the boot process to terminate.

jwhitman 04-21-2008 05:33 PM

Thanks all!

Specifying it as vfat and using the partition (e.g. dev/sdc1) makes it work. I just use the hardware browser to make sure we've got the correct device node each time. I don't know if we're using ACPI, but mounting from the command line works well enough.


All times are GMT -5. The time now is 03:53 AM.