LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-03-2008, 02:14 PM   #1
jwhitman
LQ Newbie
 
Registered: Apr 2008
Posts: 3

Rep: Reputation: 0
Red Hat: Can't mount external hard drives anymore. Was rebooted without unmounting


I have a red hat machine that will no longer detect external hard drives. It never had an icon for an external drive popping up on the desktop, but if I mounted a drive from the command line (after using the hardware browser to check where it was), it worked fine. Now, external drives still show up under /dev when I use the hardware browser, but I can no longer mount drives from the command line. I get the following error message:

sh-2.05b# mount /dev/sdc USB500
mount: you must specify the filesystem type
sh-2.05b# mount -t fat32 /dev/sdc USB500
mount: fs type fat32 not supported by kernel

When I was away, someone told me that the machine froze and had to be rebooted, so I suspect the problem resulted from an external drive not being unmounted properly before the machine was rebooted.

Any suggestions on how I can fix this?

Thanks
 
Old 04-03-2008, 02:29 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 272Reputation: 272Reputation: 272
The file type should be -t vfat, not "fat32".
 
Old 04-07-2008, 05:26 PM   #3
jwhitman
LQ Newbie
 
Registered: Apr 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by pljvaldez View Post
The file type should be -t vfat, not "fat32".
Thanks, but I still get the same error if I specify it as vfat:

sh-2.05b# mount -t vfat /dev/sdc USB500
mount: wrong fs type, bad option, bad superblock on /dev/sdc,
or too many mounted file systems

It's specified as fat32 rather than vfat on the hardware browser. Any other suggestions?
 
Old 04-07-2008, 06:41 PM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 18,496

Rep: Reputation: 3099Reputation: 3099Reputation: 3099Reputation: 3099Reputation: 3099Reputation: 3099Reputation: 3099Reputation: 3099Reputation: 3099Reputation: 3099Reputation: 3099
You mount partitions, not devices - try something like /dev/sdc1
 
Old 04-07-2008, 06:57 PM   #5
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
You should use -t vfat as suggested and use the device node for the partition rather than the entire disk.

As for the automounting problem, are you booting with NOACPI by any chance. The dbusd and hald daemons require ACPI.
That could be the cause of the underlying problem.

Also for external drives, if you add an entry in /etc/fstab, don't use the device node (eg /dev/sdc1) in the /etc/fstab entry. Instead use the filesystems label or UUID number. If you know what the device node is presently, then run "udevinfo -q env -n /dev/sdc1". (I'm using /dev/sdc1 as an example) and the use "UUID=<the_fs_uuid>" or "LABEL=<the_disk_label>" in /etc/fstab. The reason for doing this is that you don't know if a device will have the same device node the next time it is plugged in. Using the "noauto" option is a good idea as well.
That will prevent the failure to mount a removable drive at boot time from causing the boot process to terminate.
 
Old 04-21-2008, 06:33 PM   #6
jwhitman
LQ Newbie
 
Registered: Apr 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks all!

Specifying it as vfat and using the partition (e.g. dev/sdc1) makes it work. I just use the hardware browser to make sure we've got the correct device node each time. I don't know if we're using ACPI, but mounting from the command line works well enough.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to mount external HD in Red Hat linux AS3 khajarazi Linux - Hardware 1 01-16-2008 06:30 AM
Red Hat won't find 2 of me hard drives tbriden Linux - Hardware 3 09-07-2004 05:13 PM
red hat and large partitioned hard drives theCopin Linux - Newbie 5 10-28-2003 01:57 PM
Multiple physical hard drives w/Red Hat 9 masterspud777 Linux - Hardware 7 07-29-2003 05:10 PM
Windows ME and Red Hat 7 on different Hard Drives jockstrap Linux - Software 2 05-24-2001 11:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 10:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration