LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Recover/edit of /etc/inittab from GRUB (https://www.linuxquestions.org/questions/linux-general-1/recover-edit-of-etc-inittab-from-grub-196663/)

sujith_marar 06-23-2004 12:43 AM

Recover/edit of /etc/inittab from GRUB
 
How to recover/edit /etc/inittab From GRUB ( post #1)

Problem - How to Edit /etc/iniitab from Grub Bootloader
BootLoader -Grub
No of OSs-Dual
Red Hat Os 8.0
Win XP

I desperately need to come back to text mode from graphical mode by changing the runlevel mode from id:5 to id:3 in /etc/inittab as the only way of editing was through Grub (booting time) bootloader
Actions taken

if you're using grub, hit "e" at the grub screen to edit the boot commands. Then, ono the line that starts with "kernel", hit "e" again, and at the very end of the line type a "3" without the quotes. Then hit enter to accept changes, annd hit "b" to boot. This will get you into runlevel 3, which will not start x but will give you a command prompt.
Now, if you want to start in command prompt without editing grub like that, edit the file /etc/inittab and change the number 5 in the line that looks something like this...

id:5:initdefault:
change the 5 to a 3 and save it. now, after boot, you can get into x by typing:
startx
---------------------------------------------------------------------------------
When I did the above operation...............
MY GRUB BOOTLOADER shows this way

root hd(0,0)
kernel /boot/vmlinuz-2.4.18-24.8.0 ro root=LABEL=/3 (type 3 at the end of the line. Is it correct ?)
initrd /boot/initrd-2.4.18-24.8.0.img
then press boot 'b'

I get the display
'Kernel panic init not found Try option init= with kernel'
Tried various options
kernel /boot/vmlinuz-2.4.18-24.8.0 ro root=LABEL=/ 3(putting space in between)
kernel /boot/vmlinuz-2.4.18-24.8.0 ro root=LABEL=/init=3(without space)
kernel /boot/vmlinuz-2.4.18-24.8.0 ro root=LABEL=/init 3
kernel /boot/vmlinuz-2.4.18-24.8.0 ro root=LABEL=/ init=3

Same display error as above-
-----------------------------------------------------------------------------------------

Action Taken
I guess you use grub as the bootloader
on the screen of the boot press select the config you want to boot, type a
this will drop you on to a prompt. there put 3 or 5 at the end of the line.

(Press 'a' at GRUB Bootloader User Interface screen appeared)
grub append> ro root=LABEL=/3
Tried various options as above
Same kernel error
If I did not give '3' or blank
/etc/inittab showing Xserver error -since I made runlevel-5

/etc/rc.rd respawned -wait for 5 minutes
/etc/rc.rd respawned -wait for 5 minutes
/etc/rc.rd respawned -wait for 5 minutes
..............
How I can edit runlevel - 3 from GRUB(booting)
I see all files from GRUB through cat for ex: cat /etc/innitab
The only thing I wanted to edit runlevel id :5 to id:3
remmeber I cannot reach to the text mode at root prompt
THE OS is hanged at the initial booting. It is neither going here or there

Thanks
Sujit

wallykid 09-11-2004 01:19 PM

sujith_marar, i believe you have to insert a space betwee the / and the number. I have tried it on redhat 9.0 . And i got the same error you got when i do not leave a space.


All times are GMT -5. The time now is 11:01 AM.