-   Linux - General (
-   -   Rdesktop Printer Redirection (

LogiLinux 07-07-2010 09:02 AM

Rdesktop Printer Redirection

I am currently having problems trying to redirect locally-attached printers when using rdesktop (v1.6.0) from a Debian (LENNY) HP thin client (T5735) to Windows XP Pro & Windows 7 Pro machines.

When using a Windows RDP client, any locally installed printers automatically appear on the RDP server machine as "redirected" and do not need to be manually installed.

This does not happen for us when using rdesktop.

The printers *do* appear as TSxxx ports when a printer is manually installed on the RDP server machine - and prints come out correctly - so the re-direct partially works, but these installed printers disappear every time the RDP server machine is rebooted.

I have also tried an Ubuntu install and the same happens

HPLIP & CUPS are installed on the Debian installation to make sure that they have correct HP driver .

I have used varying combinations of the following parameters:

-T "Windows 7"
-a 16
-k en-gb
-g 1632x918
-x l
-n TC
-r usbrdr
-r sound:local=alsa
-r disk:usb=/media
-r printer:LP1= "Officejet_Pro_K5400"
-r lptport:LPT1=/dev/bus/usb/006/002

Firstly, is rdekstop supposed to wwork in the same manner as the Windows RDP client?

And if so, what am I doing wrong?

Thanks in advance

Tinkster 07-08-2010 02:44 AM

Not that I ever used rdesktop for this, but ... the man page suggests
a line more like:

-r printer:local_queue_name
Of course, if LP1 is the queue i have no idea ...

LogiLinux 07-08-2010 09:50 AM

yep - LP1 is the printer queue

we have tried various combinations, individually and together.

we have just got the printer redirect working using freerdp on an Ubuntu install, but would prefer to use rdesktop as this comes bundled which makes life a lot easier for our Debian setup

Thanks in advance

Lexus45 04-19-2011 04:21 AM

Hi all.

I also have a problem with printer HP LaserJet M1132, it's MFP.
It prints well locally (it's connected to the Ubuntu 11.04 machine).

We tried '... -r printer:<exact printer name as in Ubuntu> ...' and '... -r printer:<exact printer name as in Ubuntu>="<driver's name as it's named in Windows>" ...'
But all in vain. Yes, the driver of this printer is installed on the Win 2003 Server.

Then we tried another tool - Remmina. Since v. 0.8 it uses a new freerdp-protocol, it was written that it works better with printer redirection, etc. There are no any exact setting in Remmina, considered with printers. Just a drop-down menu or a radio button like "redirect local printers". Nothing changed.

Then we tried 'xfreerdp'. It's a command-line tool. It also doesn't wor with this printer. But the parametres were correct.
But! Depending on the order of parametres in the command, the 'mounted' directory and the printer do not appear simultaniously. That's what I mean:
printer. NO disk.

xfreerdp -u lexus -a 8 -z -k 0x00000409 --plugin cliprdr --plugin rdpsnd --plugin rdpdr --data disk:lexus:/home/lexus -- --plugin rdpdr --data printer -- ts1
disk. NO printer:

xfreerdp -u lexus -a 8 -z -k 0x00000409 --plugin cliprdr --plugin rdpsnd --plugin rdpdr --data printer -- --plugin rdpdr --data disk:lexus:/home/lexus -- ts1
So, printers/disk (folder) depend on the order in the command.

Does anybody know the way to fix this problem?

Lexus45 05-04-2011 05:17 AM


xfreerdp -u LOGIN -d DOMAIN -a 32 -z -g 1900x1000 -k 0x00000409 --plugin cliprdr --plugin rdpsnd --plugin rdpdr --data disk:${USERNAME}:${HOME} --plugin rdpdr --data printer --

All times are GMT -5. The time now is 03:12 PM.