-   Linux - General (
-   -   random computer freezing (

silvercat 09-13-2004 11:37 PM

random computer freezing

My computer is randomly freezing on me since yesterday. I have no idea why it is doing this or where to go about seeing why either. I have not even installed anything new in the past couple of days, so I am completely clueless as to what to do. Any suggestions? I am running Redhat 9.0.

Computer is HP Pavilion 7850

Thanks for any help.


SciYro 09-13-2004 11:53 PM

look thru the kernel logs, and any other relevant logs, to see if theres anything that might point a clue as to why its freezing, cause just saying its freezing doesn't really help much :)

silvercat 09-14-2004 12:01 AM

I feel kind of dumb with asking, but how do i check the kernel logs? :(

silvercat 09-14-2004 12:13 AM

nevermind, i think i found them. I'll see if i can find something that might help you guys help me more :)

silvercat 09-14-2004 12:36 AM

ok I didn't know what i was looking for but what about this:

Sep 13 18:56:12 localhost ifup: iptables: Bad rule (does a matching rule exist in that chain?)
Sep 13 18:56:12 localhost ifup: iptables: Table does not exist (do you need to insmod?)
Sep 13 18:56:12 localhost ifup: iptables: No chain/target/match by that name


I found it in the "boot log"

I also found this in the "system log" :

Sep 12 22:33:16 localhost modprobe: modprobe: Can't locate module sound-slot-1
Sep 12 22:33:16 localhost modprobe: modprobe: Can't locate module sound-service-1-0
{this above messege is repeated at least 5 + times]
Sep 13 04:02:03 localhost cups: cupsd shutdown succeeded
Sep 13 04:02:05 localhost modprobe: modprobe: Can't locate module char-major-188
Sep 13 04:02:05 localhost last message repeated 15 times
Sep 13 04:02:05 localhost cups: cupsd startup succeeded

it then repeats the:

Sep 12 22:33:16 localhost modprobe: modprobe: Can't locate module sound-slot-1
Sep 12 22:33:16 localhost modprobe: modprobe: Can't locate module sound-service-1-0

a couple more time only with a different date and time.

This is also in the "system log" it looks like it is repeated about 5 times.

Sep 13 20:53:56 localhost kernel: : PCI Bus error 6290.
Sep 13 20:53:56 localhost kernel: eth0: PCI Bus error 6290.
Sep 13 20:53:56 localhost last message repeated 13 times
Sep 13 20:53:56 localhost kernel: eth0: Too much work at interrupt, IntrStatus=0x8000.

Dose any of these help with understanding why my computer is locking up? I don't know what to look for so i just posted things that looked odd to me.

MartinN 09-14-2004 01:37 AM

Hi Silvercat

Have you recently added/updated hardware or software on your machine? That "PCI Bus error 6290" sounds suspicious to me! It's related to your network card. If you google for that phrase you will find some mailing list archives where people are having that problem after upgrading to a new kernel version. The remedy seems to be to move the NIC to another PCI slot.

However, if your computer has run flawlessly for weeks without any major software upgrades (like a new kernel) or any new hardware added, then I would suggest that maybe one of your memory modules has failed. Try Memtest86 to rule that out: Memtest86 is a standalone program that boots from a floppy or a CD and makes a thorough investigation of your memory (much more than the BIOS does).

Good luck!

silvercat 09-14-2004 01:52 AM

Thank you for the advise. The only thing i have installed lately was the znes emulator, but that was like a week ago and it has only started up since yesterday.

I will check out that site you gave me and see what it says.

Thank you.


silvercat 09-14-2004 06:02 PM

well, i have run into a new problem. When I try to ue the Memtest86, I typed in "lilo" like it says in the root. But I get this messege,

/etc/lilo.conf: No such file or directory

I am trying to find out why i would get this message, but with my computer locking up like it is, its getting kind of hard (strarting to have bad memories of windows right about now :(

thanks for any help

MartinN 09-15-2004 12:14 AM

Hi again!

Sorry for the late response, just woke up ;)

I don't understand. You downloaded Memtest86 and put it on a boot floppy or CD. Then you booted the machine with that. Why should you get to a lilo prompt? Are you sure that the boot order in BIOS is correct? I usually prefer the order A, CD-ROM, C. Do you know how to check/set this?


silvercat 09-15-2004 12:31 AM

hi and thanks for responding :)

I was trying to "boot disk partition via lilo" which was part of the instructions i have. it has some for a floppy drive, but my floppy drive hasn't worked for a month now and sadly since i never really used it, i never replaced it :( . I don't see any instructions for a cd but i can't get it to burn either.

UPDATE: i found out the reason i don't have LILO because i installed the GRUB loader instead (or at least this is what i think is the reason). Im taking a guess then that i will probably either have to figure out why my floppy drive is not working or get another one.

edited do to grammer and updated info.

MartinN 09-15-2004 02:59 PM

There are ISO images (for burning to a CD) at the Memtest page, but I understand it you don't have a burner. Don't you, or a friend, have an old computer that you can cannibalize for the floppy drive? They still come in handy sometimes for things like this and the excellent "Toms rescue boot floppy" (see ).


silvercat 09-15-2004 08:44 PM

Unfortinitly no :(. I just tried to see if i could fix my floppy drive, but it dosen't even look like it is registering a floppy in the drive :*( Right now I am usuing my mothers computer (who sadly has a windows instead of a linux) because mine is getting so bad with the lock ups.

I oped the inside of the computer, but all my PCI slots are filled, so I have nowhere to else to put my MIC card. The best I could do was to take it out and put it back in hoping that it would help, which didn't.

On an extra note, it looks REALLY dusty on the inside of my computer. I mean, there is dust on everything including the fans(i have 2) the graphics card, heat sink, even the mother board itself. Could this be causing some of the problems?

Thanks for any advise and help that you have given so far,

MartinN 09-16-2004 01:23 AM

Dust could definitely cause problems if your computer overheats! Do not use a vacuum cleaner inside the chassis, that could induce static electricity that kills your computer. Instead, take it outdoors and blow out the dust. Make sure to get the fans and heatsinks clean.

Maybe your computer isn't running RedHat -- it's running red hot.


silvercat 09-16-2004 05:02 PM

Well here is the update:

I cleaned the computer out like you said and by some luck my harddrive decided to work after this, so i took advantage of this and used the memtest on it.

It found erros in one of my rams so I took it out. Luckly only one of the rams were bad and the good one was the 256mb, so i should be ok with just using that for now (i hope).

now the bad news, i am still having trouble with the freezes. in the System log i am getting the same error,

localhost kernel: : PCI Bus error 6290.
localhost kernel: eth0: PCI Bus error 6290.
localhost last message repeated 13 times
localhost kernel: eth0: Too much work at

I then did what you said about moving the ehternet card. I ended up having to take my modem out of its slot(im not using it so i figured I won't need it and im getting desprite)
I am still getting the same error and freezing. I don't know what to do now since the only things left to rip out of the computer to move my ehternet card would be the graphics card (which i want to keep) and my second fan (which i should keep).

Any more suggestions? Im starting to wonder if i will use my "red hot" computer for toasting marshmellows, lol

MartinN 09-16-2004 05:27 PM

Is that error the last thing written to the log before a freeze? (Look at the time stamps.) Try removing your network card and use the computer for a while without it to see if it stops hanging then. How frequent is this problem anyway? Can you run for hours or does this appear within minutes.

I will go to sleep now (it's 11:30 PM in Sweden) so don't expect any more responses from me until tomorrow. ;)


All times are GMT -5. The time now is 12:18 PM.