-   Linux - General (
-   -   Quotas Hard Limit Problem Groups (

Ani 10-19-2009 11:14 AM

Quotas Hard Limit Problem Groups
Quotas Hard Limit Problem Groups (slackware 13)

Hi, I have setup group quotas on a particular file system.
I can setup the soft limit, hard limit, and grace period for a particular group.
I made sure quotas are running by issuing quotaon and quotaoff commands.

When I login as a user of that group that has a soft/hard limit set I can add files to the file system. When I do this I can run repquota and see the “used” column amount grow.

When the used amount gets to be greater than the soft limit I see my grace period number show up. I can continue to add files to the file system past the soft limit.

The problem I have is that I can continue to save files past the hard limit.

My soft limit is below my hard limit by 5%. I have tried various values for my soft hard limits without any luck. I have tried various grace periods from days to seconds. After my grace period is over I can still continue to add files past the hard limit.

What am I doing wrong?

chrism01 10-21-2009 02:07 AM

Have a look at this chapter Maybe you need to run quotacheck ?

Ani 10-23-2009 08:17 AM

I have run quotacheck and the command completes successfully.
I see it updating the quota files/database with the new files I create.

The problem is that I can keep creating new files. Even though I am over the hard limit.
A grace period is set for 2seconds just to make sure it is not the grace period holding me back.

I am use quota tools 3.17
Slackware 13 64-bit
EXT4 for the quota filesystem

My fstab has these options
defaults,userjquota=aquota.user,,jqfmt=vfsv0 1 2

All times are GMT -5. The time now is 05:49 PM.