-   Linux - General (
-   -   PXE-TFTP Installation Server (

dipuasks 11-23-2006 11:49 AM

PXE-TFTP Installation Server
Hi Everybody.

I am interested to setup a tftp installation server for installing through PXE. Please guide me step by step as i am confused following the redhat manual. Pls mention about:

1. The additional lines required in /etc/dhcpd.conf
2. How to configure the TFTP Server and getting it worked.

I have all packages installed i.e, dhcp, tftp-server and syslinux but i dont know how to do it all.

Thanks in advance

odcheck 11-24-2006 06:06 AM

I've done nearly everything what is described here
and it works fine.

If you run into errors come back ;-)

dipuasks 11-24-2006 01:38 PM

I'll do it...but the tutorial is for Older version of Redhat Linux,let me try with my versions (RHEL 4, FC3-6).
Thanks a lot...

odcheck 11-27-2006 02:17 AM

Doesn't matter which version in this case.
If done that on a CentOS 4.3 and I am offering NFS installs of FC6 and RHEL4
This HowTO will help you :-)

maxchock 01-15-2007 08:34 PM

I'm trying the samething, but I too bad I only get "PXE-E32: TFTP open timeout", any idea??

I can only "get xxfilexx" using root, but not others.. I have "chmod 777 /tftpboot", but still no luck. Have anyone met the same problem i met??


shantanu_gadgil 12-02-2008 11:58 AM

What did the trick was:
1. Keep the DHCP (dhcpd) and the TFTP (xinetd + tftp) server on the same machine.
2. use the DHCP directive "next-server" to point to the same machine.

What I have also observed is that this is related to the LAN card...
It works OK for an Intel card but the timeout thing happens for a RTL 8139 chipset card.

Maybe using dnsmasq might give people different results ???


shantanu_gadgil 12-04-2008 02:44 AM

The PXE-E32 timeout error has many reasons, probably !!!

The following were my findings in regards to the "PXE-E32" problem.

I'll note my setup in case it might help others ...

Server side was dhcpd on Fedora Core 7 (seven) x86_64
The dhcpd.conf had the next-server directive which was pointing to another machine running dnsmasq as the TFTP server.

* The above setup works flawlessly if I use an Intel LAN card.
* The same setup DOES NOT work with the onboard (crappy?) RTL8139 card.
* IF I move the TFTP supplied files on the same machine as the one running my dhcpd, then the same RTL8139 cards netboots OK (!) ... sometimes !!! :(
* If I use the gPXE ISO for my LAN card, the "dhcpd and tftp separate" setup works OK ... all the time.

From the above I have concluded (at least for myself :)) that the LAN card PXE loader IS at fault. ( I guess the TFTP client part, but not sure)

If I really need to PXE boot from my RTL8139 LAN card, I'm going to use the gPXE ISO.

For now, I have disabled my onboard LAN and fit an Intel LAN card, and life is happier!!! :) :)


All times are GMT -5. The time now is 11:15 AM.