LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-25-2005, 04:28 AM   #1
rhoekstra
Member
 
Registered: Aug 2004
Location: The Netherlands
Distribution: RedHat 2, 3, 4, 5, Fedora, SuSE, Gentoo
Posts: 372

Rep: Reputation: 42
Putty and Character encoding problems


Hi,

It's not the first thread concerning this, I know. Still, I am unable to find the solution...

I have a Fedora Core 3 system as my Linux router.
I have a Windows client to work on, with Putty to connect to the router.

As RedHat has a preference for utf-8 for a while now, I don't want to mess with the '/etc/sysconfig/i18n' file, leaving it as:

Code:
LANG="en_US.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en"
SYSFONT="lat0-sun16"
Though, when I connect using Putty, weird things happen. I narrow this topic down to mc (midnight commander) and iptraf, but it carries further that this (like man pages (for certain characters) and other, line drawing, applications).

I created the following table with encodings and results:

Code:
+---------------+---------------+-----------+---------------+
| Putty setting | LANG variable | MC result | iptraf result |
+---------------+---------------+-----------+---------------+
| UTF-8         | en_US.UTF-8   | OK        | X (lqqqk)     |
| ISO 8859-15   | en_US.UTF-8   | X (��)    | OK            |
| ISO 8859-15   | en_US         | OK        | OK            |
| UTF-8         | en_US         | X (lqqqk) | X (lqqqk)     |
+---------------+---------------+-----------+---------------+
I could change the LANG in /etc/sysconfig/i18n to not have the UTF-8 suffix. This is, as written above, not desirable, as utf-8 is the RedHat/Fedora default.

The question is, is there a good way (besides poor man's drawing) to have the linux box have the UTF-8 encoding and putty display it right on all occasions?

I would appreciate all the help . . .
 
Old 07-30-2007, 03:45 PM   #2
penguin359
LQ Newbie
 
Registered: Jul 2007
Distribution: Gentoo Linux
Posts: 3

Rep: Reputation: 0
Make sure you have Putty configured to accept UTF-8 encoded data instead of Windows-1252. The setting is under Window->Translation->Character set.
 
Old 07-30-2007, 03:46 PM   #3
penguin359
LQ Newbie
 
Registered: Jul 2007
Distribution: Gentoo Linux
Posts: 3

Rep: Reputation: 0
Make sure you have Putty configured to use UTF-8 for it's character set and not Windows-1252/ISO-8859-1. The setting is under Window->Translation->Character set.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Character encoding problems eduac Linux - Software 5 08-02-2005 06:48 PM
Acroread, Character Encoding Problems, and plug-in setup wrw3 Linux - Software 0 12-15-2004 01:17 AM
C Multibyte character encoding ugenn Programming 0 12-14-2003 07:44 AM
character encoding - mandrake 9.2 Osten Mandriva 1 11-21-2003 11:09 AM
Unsupported Character Encoding yenonn Linux - Software 3 04-28-2003 05:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 07:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration