-   Linux - General (
-   -   Problems with folder permissions, and truecrypt. (

spicyed 09-28-2006 12:49 AM

Problems with folder permissions, and truecrypt.

I have an ftp server, and the drive which holds the data in ftp root is contained in a truecrypt volume. This drive is /dev/hda.

I mount this drive to where the ftp root is set to, let's call it /var/ftp/, using truecrypt

i run:

truecrypt /dev/hda /var/ftp

I enter the password, and the drive is mounted. All the files already on the drive can be accessed and downloaded by all on the ftpserver. However, only root has permission to write to this drive. Whether local or from ftp.

I figured that I would be able to chmod the device by "chmod -R a+rwx /var/ftp/" or chmod'ing new folders inside the mounted drive.

This does not give me write permissions as it should for the drive. Is there something that I am doing wrong, or could it be truecrypts fault for not allowing me to chmod the drive?

mickyg 09-28-2006 05:40 AM

Have you looked at changing the mount options for the drive in /etc/fstab?? That way you won't need to chmod everytime the drive is mounted.

spicyed 09-28-2006 12:31 PM


Originally Posted by mickyg
Have you looked at changing the mount options for the drive in /etc/fstab?? That way you won't need to chmod everytime the drive is mounted.

Well the problem is not that I have to chmod, it's that I can't. Chmod has no effect, and also gives me no error.

haertig 09-28-2006 12:56 PM

I would ask on the TrueCrypt forums. To get into the "Problems-Linux" or "Problems" subforums, you need to setup a userid. Not so for the "General" subforum. Not sure why that is. I did a quick search using my id on "write permissions" for the Problems-Linux subforum, and there were quite a few hits. I don't have the time at the moment to research through them all so I can't give you any definite answers, but I'm guessing you can find what you need in those forums.

spicyed 09-28-2006 01:05 PM

I've already asked there, so far nothing. :-p

Thanks though.

tolohosh 10-04-2006 06:39 AM

Hi freinds,

I install fedora 5 in the second hard disk and windows xp in the first hard disk but i can't mount hda in the fedora and i see error PERMISSIONS DENIED.I enter in the root but I see same error again.Please help me.Here is my fstab

/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0

haertig 10-08-2006 05:58 PM

I just had another thought on this pop into my head (yeah, I know, about two weeks too late!)


Originally Posted by spicyed
i run:

truecrypt /dev/hda /var/ftp

Did you try mounting the truecrypt volume with the -u option?


truecrypt -u /dev/hda /var/ftp
From the command "man truecrypt"

      -u, --user-mount

              Set default user and group ID of the filesystem being mounted to
              the user and group ID of the process which  executed  TrueCrypt.
              Some filesystems (like FAT) do not support user permissions and,
              therefore, it is necessary to supply a default user and group ID
              to the system when mounting such filesystems.

Micro420 07-31-2008 01:27 PM

The solution is to use the truecrypt --fs-option. for example:

truecrypt --fs-option="uid=1000,gid=1000,umask=0002" mount-point/

All times are GMT -5. The time now is 05:33 PM.