LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 10-16-2002, 06:01 AM   #1
qanopus
Senior Member
 
Registered: Jul 2002
Location: New York
Distribution: Slackware
Posts: 1,358

Rep: Reputation: 45
problems shutting down the computer.


Hi there guy's. A month or so ago I posted this thread .

As you can read I had (and still have) problems shutting down my machine. I don't know what to do about this. I have installed the proper nVidia drivers, but this didn't help. Here is my XF86config file:

# /.../
# SaX generated XFree86 config file
# Created on: 2002-10-03.
#
# Version: 4.3
# Contact: Marcus Schaefer <sax@suse.de>, 2001
#
# Automatically generated by [SaX2] (4.3)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
ModulePath "/usr/X11R6/lib/modules"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "type1"
Load "speedo"
Load "extmod"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
Driver "Keyboard"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc101"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "ButtonNumber" "5"
Option "Device" "/dev/mouse"
Option "InputFashion" "Mouse"
Option "Name" "Autodetection"
Option "Protocol" "imps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
HorizSync 27-48.4
Identifier "Monitor[0]"
ModelName "1024X768@60HZ"
VendorName "--> VESA"
VertRefresh 50-60
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "640x480" 23.96 640 656 720 864 480 480 487 501
Modeline "1024x768" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
EndSection


Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "GeForce3"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
VendorName "NVidia"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection


Does any one see anything wrong here ? Also, in the nVidia readme file, I read that stability problems could be AGP related. Here is the related section :

If you are experiencing AGP stability problems, you should be aware of
the following:

o Support for the processor's Page Size Extension on Athlon Processors

Some linux kernels have a conflicting cache attribute bug that is
exposed by advanced speculative caching in newer AMD Athlon family
processors (AMD Athlon XP, AMD Athlong 4, AMD Athlon MP, and Models 6
and above AMD Duron). This kernel bug usually shows up under heavy use
of accelerated 3D graphics with an AGP graphics card.

Linux distributions based on kernel 2.4.19 and later *should*
incorporate the bug fix. But, older kernels require help from the user
in ensuring that a small portion of advanced speculative caching is
disabled (normally done through a kernel patch) and a boot option is
specified in order to apply the whole fix.

Nvidia's driver automatically disables the small portion of advanced
speculative caching for the affected AMD processors without the need
to patch the kernel; it can be used even on kernels which do already
incorporate the kernel bug fix. Additionally, for older kernels the
user performs the boot option portion of the fix by explicitly disabling
4MB pages. This can be done from the boot command line by specifying:

mem=nopentium

Or by adding the following line to etc/lilo.conf:

append = "mem=nopentium"

o AGP drive strength BIOS setting (Via based mainboards)

Many Via based mainboards allow adjusting the AGP drive strength in
the system BIOS. The setting of this option largely affects system
stability, the range between 0xEA and 0xEE seems to work best for
NVIDIA hardware. Setting either nibble to 0xF generally restults in
severe stability problems.

If you decide to experiment with this, you need to be aware of
the fact that you are doing so at your own risk and that you may
render your system unbootable with improper settings until you
reset the setting to a working value (w/ a PCI graphics card or
by resetting the BIOS to its default values).

o System BIOS version

Make sure to have the latest system BIOS provided by the board
manufacturer.

o AGP Rate

You may want to decrease the AGP rate setting if you are seeing
lockups with the value you are currently using. You can do so
with the NVreg_ReqAGPRate NVdriver module parameter.

If you are inserting the module manually:

insmod NVdriver NVreg_ReqAGPRate=2 # force AGP Rate to 2x
insmod NVdriver NVreg_ReqAGPRate=1 # force AGP Rate to 1x

If you are using modprobe (/etc/modules.conf):

alias char-major-195 NVdriver
options NVdriver NVreg_ReqAGPRate=2 # force AGP Rate to 2x
options NVdriver NVreg_ReqAGPRate=1 # force AGP Rate to 1x


On Athlon motherboards with the VIA KX133 or 694X chip set, such as the
ASUS K7V motherboard, NVIDIA drivers default to AGP 2x mode to work around
insufficient drive strength on one of the signals. You can force AGP 4x
by setting NVreg_EnableVia4x to 1. Note that this may cause the system
to become unstable.

On ALi1541 and ALi1647 chipsets, NVIDIA drivers disable AGP to work
around timing issues and signal integrity issues. You can force AGP
to be enabled on these chipsets by setting NVreg_EnableALiAGP to 1.
Note that this may cause the system to become unstable.


But this is all rather criptic to me, and I don't want to do anything wrong here. I could get in to big trouble. Could any one help me ?
My system specs are listed in the thread I pointed to at the beginning of this message

Last edited by qanopus; 10-16-2002 at 06:03 AM.
 
Old 10-16-2002, 06:05 AM   #2
qanopus
Senior Member
 
Registered: Jul 2002
Location: New York
Distribution: Slackware
Posts: 1,358

Original Poster
Rep: Reputation: 45
And a nother thing, I tried giving the "mem=nopentuim" option to lilo. It didn't work
 
Old 10-16-2002, 01:51 PM   #3
mrGee
Member
 
Registered: Dec 2001
Location: Netherlands
Distribution: redhat suse mandrake freebsd
Posts: 344

Rep: Reputation: 30
Hi
Quote:
And a nother thing, I tried giving the "mem=nopentuim" option to lilo. It didn't work
i assume you did rerun lilo afterwards ? and you actually
typed mem=nopentium and nopentuim is a typo here and not in your lilo.conf ?
To check do dmesg|less and see what is after;
Kernel command line:
I have to use it to keep my X stable, and i do have an
AMD inside. My errors without it were; total freeze up in
X whilst doing certain opengl things games, blender etc.

From your previous thread i understand that you are quite
sure it is an X related shutdown error.
Maybe go into runlevel 3 before shutting down;
go to console
be root
type; telinit 3
then; shutdown -h now
I had an issue concerning the loginmanager kdm, i use
gdm now instead ; the problem related to falling back to
runlevel 3 in every 10-20 boot up.
good luck
 
Old 10-17-2002, 06:06 AM   #4
qanopus
Senior Member
 
Registered: Jul 2002
Location: New York
Distribution: Slackware
Posts: 1,358

Original Poster
Rep: Reputation: 45
Hello.

Yes, the "mem=nopentuim" thing is a typeo (I know I did it again).
I have tried giving the command to lilo directly at boot-up and after that I edited the lilo.conf file. I didn't forget to run lilo.

Do be frank, I am not absolutely sure that it is X thats causing the problem. Are you familiar with suse ? If you are you might have seen that the first console in suse (you know, the one excesible with cnrl-alt-f1) is semi-graphical. It's not X, but you do see nice pictures of tux for instance. I think I have trouble getting I or out if that console. Cos in very rear cases the problem has occurd when I was just switching to that console.
I hope you have a good picture in your mind on how the fist suse console looks like. Some one told me it woks via a frame-buffer device, but I have no clue on what that is.

Appreciate the reply. Could you help me some more ?
 
Old 10-17-2002, 08:12 AM   #5
Mik
Senior Member
 
Registered: Dec 2001
Location: The Netherlands
Distribution: Ubuntu
Posts: 1,316

Rep: Reputation: 47
Well if it happens whenever you switch to the first console then it could very well be problems with the frame buffer device. Since you work in graphical mode you probably won't have any benefit from it, except watching the nice little penguin when it boots up. So why don't you try compiling a kernel without frame buffer support. You can turn it off in the Console drivers section of the kernel configuration.
 
Old 10-17-2002, 08:17 AM   #6
qanopus
Senior Member
 
Registered: Jul 2002
Location: New York
Distribution: Slackware
Posts: 1,358

Original Poster
Rep: Reputation: 45
He, thanks man. Is there any way of just turning off the frame buffer device ?
I am planing to re-compile my kernel any way, even if it isn't possible, no problem
 
Old 10-18-2002, 11:55 AM   #7
mrGee
Member
 
Registered: Dec 2001
Location: Netherlands
Distribution: redhat suse mandrake freebsd
Posts: 344

Rep: Reputation: 30
change in your lilo.conf vga=771 (or whatever number) into;
vga = normal
rerun lilo
reboot;
and your first console lives as naked as it was
good luck
 
Old 10-18-2002, 08:40 PM   #8
jkcunningham
Member
 
Registered: May 2002
Location: Seattle, WA, USA
Distribution: Gentoo
Posts: 136

Rep: Reputation: 15
I have SuSE 8 running on five machines, four of them different hardware. I have observed what might be the same problem. When trying to either log off or shut down they will sometimes hang after sending the terminate signal. The screen changes slightly, the panels either disappear or at least change. And it is generally not responsive to the mouse or the keyboard.

With one exception: I can always C-M-F3 and log on a text screen, then do a ps -A and start killing what I'll call "high level" processes which will invariably be still running. For example, there seems to be a bug in acroread which will leave a process running in the background which will hang up the shutdown process until it is killed. Some applications like nautilus, opera, konqueror, etc, if left running when attempting to log off or shutdown, will also hang it up. All I have to do though, is kill them and it goes on and completes its process.

Since then I just make sure I have nothing but terminal windows open when I log off or shut down. It would be nice to not have to do this, however. (It would also be really nice if terminal windows would open back up to the paths they were at when they were shut down!).
 
Old 10-19-2002, 10:22 AM   #9
qanopus
Senior Member
 
Registered: Jul 2002
Location: New York
Distribution: Slackware
Posts: 1,358

Original Poster
Rep: Reputation: 45
He he he, thanks a million jkcunningham. Now I won't have to hard reboot my machine any more. By the way, How dit you know that you must press C-M-F3 ?
I thinks it's realy bad that prog. keep on running on the background and cause system's to hang. They sould realy disign there apps better.

Again man thanks. mrGee and Mik, also many thanks to you.

Bey.
 
Old 11-28-2002, 01:42 PM   #10
jkcunningham
Member
 
Registered: May 2002
Location: Seattle, WA, USA
Distribution: Gentoo
Posts: 136

Rep: Reputation: 15
In case anyone's interested: I recently installed SuSE 8.1 and so far have not seen a recurrance of this logout problem, no matter what I've had up and running at the time. Its a definite improvement. Now, if they would just put Octave back into the distro I would be completely happy....
-Jeff
 
Old 11-28-2002, 02:55 PM   #11
Ciccio
Member
 
Registered: Nov 2002
Location: Paraguay
Distribution: Mandrake 10
Posts: 573

Rep: Reputation: 30
ok... why don't you write in a console #init 1 and then just cut the power off???
 
Old 11-28-2002, 04:41 PM   #12
qanopus
Senior Member
 
Registered: Jul 2002
Location: New York
Distribution: Slackware
Posts: 1,358

Original Poster
Rep: Reputation: 45
Hi there,
What do you mean Ciccio? I can't even get to a console when this happens. Any way, I doesn't matter any more. I switch to another distro. I'm using debian now. I don't know if it will solve the problem though. I'f only been using it for a couple of day's. If it does'nt, well then you'l see a grown man cry. ()
 
Old 11-28-2002, 04:45 PM   #13
qanopus
Senior Member
 
Registered: Jul 2002
Location: New York
Distribution: Slackware
Posts: 1,358

Original Poster
Rep: Reputation: 45
O and a completly different thing, how do you people edit the info you see in the box to the left here. It say's "Distribution: SuSE" How do you change that?
And another thing. pushing C-M-F3 did'nt work for me. Maby it's because i was using suse 7.3 and you were talking about 8.0

Last edited by qanopus; 11-28-2002 at 04:48 PM.
 
Old 11-29-2002, 04:21 AM   #14
Mik
Senior Member
 
Registered: Dec 2001
Location: The Netherlands
Distribution: Ubuntu
Posts: 1,316

Rep: Reputation: 47
Click the User CP button way on top next to the penguin logo. You have to be logged in to be able to see this button though.
 
Old 11-29-2002, 08:09 AM   #15
Ciccio
Member
 
Registered: Nov 2002
Location: Paraguay
Distribution: Mandrake 10
Posts: 573

Rep: Reputation: 30
Ok I meant before shutting down your system switching to a console (ctrl + alt + F1) and AS ROOT typing init 1 (for Single User) and then a command like poweorff (don't know if it works in suse)

Debian, as far as I know, is one of the best distros... but if you are looking fore something a little bit more user-friendly then you should try Mandrake 9.0 with kde3.0

IMHO MDK9.0 with KDE3.0 has an excellent balance between the features of UNIX and the user-friendlyness of a full graphical OS (like MacOS or Windows). And you can always use the console mode for certain operations that can only be done from there (or that it is faster to do so)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutting Down Computer, from Fluxbox.. ? jmr0311 Linux - Software 4 08-20-2004 12:59 AM
Shutting Down The Computer marvelous Linux - Newbie 13 08-01-2004 02:03 AM
computer keeps shutting down mjkramer Linux - Newbie 1 10-04-2003 06:40 AM
Computer not shutting down Trebor Linux - Newbie 5 08-15-2003 05:33 AM
shutting down computer w/o KVM jonfa Linux - Networking 6 05-29-2001 06:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 07:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration