-   Linux - General (
-   -   Problems installing linux on an old iMac G3 (

badbit 09-26-2011 02:03 PM

Problems installing linux on an old iMac G3
I have an old iMac G3 (333 mhz, 256 mb RAM, 160 GB HD). I used it to listen to music and online radio, but it's so limited now that I wanted to install a lightweight linux distro to bring it back to life.

I've tried a number of distributions and none of them work. At first they booted from CD and then said that they couldn't mount the filesystem. So I erased the MacOS X partition and reformated the drive with the UNIX filesystem. Still, every distribution I've tried crashes when trying to boot the kernel (Yellowdog, Slackintosh, Xubuntu, FreeBSD).

The last one I tried was Finnix, and when I tried to boot the kernel the following message appeared:


cd:2,/boot/linux: Unknown or corrupt filesystem.
I can't even use fdisk as no distribution will boot. I don't want to do anything fancy with my iMac, I just want a bash prompt and some basic tools like vim and ssh. Any ideas?

corp769 09-26-2011 02:08 PM


Puppy linux also comes to mind -
I suggest that you run a live CD first to try to see what's up with your hard drive, since you are getting that error.



badbit 09-26-2011 02:11 PM

Is that PowerPC based? To my knowledge it isn't. My iMac it's not an Intel one, that greatly restricts the distributions I can try.

corp769 09-26-2011 02:15 PM

Ehh, that will do it man. How about the "sledgehammer" distro? ;)

badbit 09-26-2011 02:35 PM

Do you have a link? Can't seem to find it.

corp769 09-26-2011 02:59 PM

You didn't get the joke....

Anyway, I advise you to check over on distrowatch and grab a live cd version, so that why you can try to mount your hard drive and troubleshoot from there.

badbit 09-26-2011 03:22 PM

I'm sorry, I'm not a native english speaker.

Finnix is a Live CD version and didn't work either. :(

TobiSGD 09-26-2011 03:45 PM

I had no problems to set up Debian, Mint 9 PPC and Frugalware on an old iMac G3 (350 MHz, 512MB RAM, 40GB HDD). I just started from the install CDs and went through the different installers with accepting the standard options. Be aware that you need at least 3 partitions on that machines, but the installers should explain that.
Also be aware that you may have to make a fix to the X server configuration once you get that going:

badbit 09-26-2011 05:24 PM

I just tried Debian Minimal. It presents me with the "boot" prompt, I type "install", then it shows:


Please wait, loading kernel. . .
And after what appears to be an eternity, it shows:


Read failed.
And goes back to "boot:" That has happened with every distribution I have tried.

I'm burning then on a CD-RW, could that be the problem?

TobiSGD 09-26-2011 05:26 PM

Yes, that can be the problem, I have used ordinary CD-Rs. Also, I just pressed enter at the boot prompt, IIRC.

badbit 09-26-2011 05:45 PM

Can't believe the CD-RW was the problem, I have just booted Finnix!

Thanks for your time.

corp769 09-26-2011 09:16 PM


Originally Posted by badbit (Post 4482971)
Can't believe the CD-RW was the problem, I have just booted Finnix!

Thanks for your time.

LOL.... I would have never expected for a disc to be the issue in this case. Glad to hear everything is fine now!

All times are GMT -5. The time now is 01:21 AM.