-   Linux - General (
-   -   Problems Finding a Video Player (

newbie2linux 01-20-2004 02:09 PM

Problems Finding a Video Player
I've been having problems installing and using MPlayer on my machine, which runs on RedHat 7.2. Do any of you know how I could rectify this problem? Or, if not, the location of another video player for Linux? Any help you could give would be much appreciated.

TheOther1 01-20-2004 03:31 PM

I like xine

Greyweather 01-20-2004 04:07 PM

VideoLAN Client is another good one.

What kind of problems did you have with MPlayer? When did the error occur and what error messages did it give you?

newbie2linux 01-20-2004 05:21 PM

I downloaded the 3 RPMs required, and tried to install it using the following code:

rpm -Uvh mplayer-common-0.90rc3-1.i386.rpm mplayer-gui-0.90rc3-1.i386.rpm mplayer-skin-default-1.6-3.noarch.rpm

When I tried installing it, I got this:

warning: mplayer-common-1.0pre3-1.i386.rpm: V3 DSA signature: NOKEY, key ID 28a2 6067
warning: only V3 signatures can be verified, skipping V4 signature
error: Failed dependencies: is needed by mplayer-gui-1.0pre3-1

h/w 01-20-2004 05:45 PM

well, u have to get those libs installed first.

newbie2linux 01-20-2004 05:47 PM

where can I find those libs?

h/w 01-20-2004 05:49 PM

look under the distro version that u run

also , while ur at it, get "apt" installed.

newbie2linux 01-20-2004 05:55 PM

would I just download Irzsz-0.12a-5.src.rpm to the "/" directory and use the syntax 'rpm -i <filename>'?

and what's apt?

h/w 01-20-2004 06:22 PM

umm, didnt the error message say u have to get libmp3lame? whats lrzsz? and u dont download rpm's with "src" in it. those are not what ur looking for. look for the corresponding ones without ".src". save the file wherever u want, and as root, "rpm -ivh <filename>".

apt is a tool that would have gotten all the packages that are needed to install something on-the-fly. in this case, it would have downloaded and installed libmp3lame for you without a bother. search for "apt" in these forums - lot has been said bout it already.

acid_kewpie 01-20-2004 06:24 PM

no, that's a source (src) rpm.. it's jsut the raw code... not really what you want. get one with i386, i586 or i686 in it.

and what is this file you picked?? you need the "lame" libraries for mp3 decoding.

newbie2linux 01-20-2004 06:37 PM

I got it working. Thanks a lot for your help, guys. It's much appreciated.

h/w 01-20-2004 06:39 PM


newbie2linux 01-20-2004 06:45 PM

Ehh....just one more question, if you'd be so kind. I'm trying to play an MPEG, and this is the error I'm getting:

Error opening/initializing the selected video_out (-vo) device.

How do I solve this problem? It would be really great if you could help out once more.

h/w 01-20-2004 07:05 PM

what was the command u ran?

newbie2linux 01-20-2004 07:07 PM

from a terminal, I ran gmplayer, and everything was working fine, and the window and control panel with the play controls popped up.

when I tried to open an MPEG, or an AVI for that matter, it gave me the error I previously posted.

All times are GMT -5. The time now is 07:14 PM.