LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - General (http://www.linuxquestions.org/questions/forumdisplay.php?f=1)
-   -   problem with read only usb filesystem (http://www.linuxquestions.org/questions/showthread.php?t=4175447210)

loneguolf 01-25-2013 01:30 PM

problem with read only usb filesystem
 
hi everyone, as you an see, im new here, so go easy on me.
well, i am not new to linux,, but i lack bash scriipting ability, and i think im gonna need it for my problem
the case is : i have a 16 GB usb stick that i used for installing systems to other machines, someday, and somehow, it screwed up, i dont know why, but im kinda sure it was the PC-BSD iso faullt, well, i cant format it, not even with Gparted, i tried sudo dd if=/dev/zero of=/dev/sdb ... it didnt work, the thing said me that it cant be written, so i tried sudo shred -vfz /dev/sdb, i also failed, those are my only two massive destruction commands, and they failed, so im beat, i tried formating with that thing called window$, it failed too
i tried to mount it read write, but still the problem persists, testdisk also failed, andthat didnt help i ran outta options, i dont know what to do now, i searched the web too, but that didnt help
so i came here, someone can please help me?, but dont rush at me because im a nOOb, i know i am, but still i can learn
so.. who can help me with this?
regards
loneguolf

sorry for the bad english

ukiuki 01-26-2013 07:31 AM

Have you tried to recreate the partition table before try to format the drive? That is easy with Gparted.

Regards

michaelk 01-26-2013 09:03 AM

Welcome to LinuxQuestions

Flash drives do fail. I assume the drive does not have a mechanical write protect switch nor have you used any special protection, encryption software etc.

loneguolf 01-26-2013 09:36 AM

hello you two, glad to meet'cha
well, i also tried recreating the partition table, with Gparted, but it fails, and there is no hhardware switch on the USB

DavidMcCann 01-26-2013 11:30 AM

If you can't do anything with Gparted, the hardware is probably broken. The weak point in USB sticks is where the plug is joined to the circuit board. If you bend it sideways when you plug it in, then that joint is strained and it will eventually fail.

loneguolf 01-26-2013 11:56 AM

whoa, now thats some pretty sad stuff
well, its not bended, but i bet thats the problem, i knew commands like data destroyer or shred are too powerfull to fail due to software problems, but they can do nothing with hardware failure
thanks for the help, next time im gonna buy a 32 gb memory, i need moar space for the multisystem live cds
so, the trhead is done, you can close it now
thanks again


All times are GMT -5. The time now is 11:02 PM.