-   Linux - General (
-   -   problem with putty displaying the right charactors (

linu 12-08-2006 02:49 AM

problem with putty displaying the right charactors
hi all

i have tried this on both debian and fedora and it has the same problem. when logged in on the server with putty it works fine on the command line etc but when in vi editing file when i press the numbers on the num pad they show as letters not numbers. but when on the commd line i press the same ones and they are come out as numbers as the should do.

any idea what the problem could be.

thanks for any sugguestion

blackhole54 12-08-2006 09:20 AM

IIRC, PuTTy comes with some pretty good documentation. Have you looked through it? I think I remember some discussion about how keys get interpreted in different circumstances.

linu 12-08-2006 12:17 PM

i have look at the documention and tried the things they said to do but nothing makes any difference:scratch:

cdex 12-08-2006 02:40 PM

Are you sure its an putty issue ? Have you access to the server, can you test if (or not) this happens with the real keyboard too ?

With vi you get letters for the arrow keys (and disabled numlock) in insert-mode (tested this a minute ago on solaris, i hope this behaves similar). I often use vim, there you can configure it. In standard debian-configured vim this is off (you get movement by pressing arrows). (at least i never noticed such behaviour of vim in my debian)

maybe this helps

blackhole54 12-09-2006 05:41 PM

I think I replicated your problem, but I had to use a bit of a kludge to do it (so maybe the results aren't reliable). The only MS machine I had to run PuTTY on was a laptop w/o a regular 10-key pad. The only way I could create the problem was to plug in a regular keyboard, and w/o going into all of the gory details, this had a few strange interactions. But with NUM-LOCK on such that the 10-key produced numbers on the command line, in vim (called vi on this installation), the 10-key produced letters plus a little weirdness. Checking "Disble application keypad mode" (Terminal -> Features) in PuTTY made the 10-key behave as expected. See section 4.6.1 of the PuTTY user manual for an explanation.

EDIT: BTW, I tried sshing into the same machine from a Linux box using the openssh client and tried the same thing. There were no problems. So despite what the PuTTY manual says, I really don't know where the fundamental problem lies.

All times are GMT -5. The time now is 08:14 AM.