-   Linux - General (
-   -   problem with power management (

gkcom 01-03-2005 08:34 AM

problem with power management
i am using fedora core 2
my Xscreensaver version is 4.14.
when i log in as a root , power management (standby,suspended ,off option ) works properly ,but when i login as a normal user it doesnt respond (nothing work )
what i have to do to use this Xscreensaver as a normal user .
anticipating a reply

blueplazma 01-03-2005 04:28 PM

There's a chance your ACPI (if you use it...) scripts are non-readable unless you're root or something to that effect. It's almost certainly a permissions problem, since it works for root. I suggest you try to run xscreensaver from a terminal and look at the errors. It could also be some daemon that gets started by root... I don't entirely know, this isn't something I know a ton about.

gkcom 01-04-2005 12:31 PM

when i run xscreensaver in a terminal it gives following error
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

xscreensaver: Can't open display: :0.0
xscreensaver: initial effective uid/gid was root/root (0/0)
xscreensaver: running as nobody/nobody (99/99)
xscreensaver: This is probably because you're logging in as root. You
shouldn't log in as root: you should log in as a normal user,
and then `su' as needed. If you insist on logging in as
root, you will have to turn off X's security features before
xscreensaver will work.

Please read the manual and FAQ for more information:

when i run as normal user it gives following message
xscreensaver: 00:03:10: already running on display :0.0 (window 0xa00001)
from process 2283 (gunjan@localhost.localdomain).

All times are GMT -5. The time now is 01:18 PM.