LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 08-02-2003, 11:00 AM   #1
jam88win
LQ Newbie
 
Registered: Jul 2003
Posts: 5

Rep: Reputation: 0
problem with Java2 RE 1.4.1-04 for Limeware


I installed the Java 2 RE 1.4.1_04 by unzipping it and running the RPM file. Now i don't know where the package got installed. And when i try to install limeware iam getting the following error message ........

____________________________________________________

sh LimeWireLinux.bin
Preparing to install...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...
No Java virtual machine could be found from your PATH
environment variable. You must install a VM prior to
running this program.
_____________________________________________________

Anybody who can help me plz......... Thanks in advance for the help...........
 
Old 08-02-2003, 03:53 PM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 417Reputation: 417Reputation: 417Reputation: 417Reputation: 417
You can always try whereis java or which java to find out where your java is installed. Then you will have to add that directory to your PATH either in your /etc/profile or your local config file.
 
Old 08-02-2003, 10:36 PM   #3
jam88win
LQ Newbie
 
Registered: Jul 2003
Posts: 5

Original Poster
Rep: Reputation: 0
thanks for ur commands but still iam getting it

_________________________________________

which java
/usr/bin/which: no java in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin)

__________________________________________

wat to do .......help me , i have installed java RE correctly
 
Old 08-03-2003, 07:07 AM   #4
zero_copy
Member
 
Registered: Aug 2003
Location: CT
Distribution: Slackware
Posts: 45

Rep: Reputation: 15
what u need to do is set the environment variables, preferably in your rc.local or /etc/profile for system wide settings, or u could use the user .profile. just make sure it gets 'sourced' before you run anything that requires java. heres the lines u need to add:

*java should be installed to somewhere like "/usr/local/j2re_1.4.0/"

PATH=/path/to/java/bin:$PATH
JAVA_HOME=/path/to/java/directory
export JAVA_HOME
export PATH

watch out for the first 2 lines, include the "/bin:$PATH" on the first line but not the second. that should do the trick. have fun
 
Old 08-03-2003, 07:44 AM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 417Reputation: 417Reputation: 417Reputation: 417Reputation: 417
Oops. My bad. I missed that you had just installed the JRE and not the full JDK. Zero_copy has it right, you need to find your j2re directory (/usr and /usr/local are the best places to look) and then add the lines zero_copy suggests to your /etc/profile or ~/.bashrc file.


Just to explain what happend with the which java command: It was looking for the java compiler, which isn't installed when you install just the JRE.
 
Old 08-03-2003, 10:38 AM   #6
jam88win
LQ Newbie
 
Registered: Jul 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks Zero_copy........Everything is fine and working properly Limeware... Does Limeware get disconnected so easily..........ie.
it connects very slowly as well... UR comments plz.....

Thanks all of u
 
Old 08-03-2003, 06:40 PM   #7
zero_copy
Member
 
Registered: Aug 2003
Location: CT
Distribution: Slackware
Posts: 45

Rep: Reputation: 15
well i have used limewire on both dialup and cable....i cant stand limewire on dialup, at least with some P2P u can manage....but limwire(for me) is pretty much unuasable with a dialup....works great with a cable/dsl though....go figure.
 
Old 02-15-2004, 01:17 PM   #8
lowlyfe
LQ Newbie
 
Registered: Feb 2004
Location: Wisconsin
Distribution: Suse 9.2 Slackware 10.1 Mandrake 10
Posts: 3

Rep: Reputation: 0
same thing

I too get that error but I cant seem to get it to work. When I type whereis java it tells me it is in /usr/share/java. but that doesn't work when I enter that in to ./profile or ./rclocal. I looked in /usr/local and there no java folder there. I did find java in /usr/java/j2re1.4.2_03. So I entered:

PATH=/usr/java/j2re1.4.2_03/bin:$PATH
JAVA_HOME=/usr/java/j2re1.4.2_03
export JAVA_HOME
export PATH

i entered that in to profile, and rc.local......but when i run which java i still get

[root@localhost root]# which java
/usr/bin/which: no java in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin)

so now im really confused because what has been suggested worked for the last guy but why isn't it working for me?

my /etc/profile looks like this:

# /etc/profile

# System wide environment and startup programs, for login setup
# Functions and aliases go in /etc/bashrc

PATH=/usr/java/j2re1.4.2_03/bin:$PATH
JAVA_HOME=/usr/java/j2re1.4.2_03
export JAVA_HOME
export PATH

pathmunge () {
if ! echo $PATH | /bin/egrep -q "(^|:)$1($|:)" ; then
if [ "$2" = "after" ] ; then
PATH=$PATH:$1
else
PATH=$1:$PATH
fi
fi
}

# Path manipulation
if [ `id -u` = 0 ]; then
pathmunge /sbin
pathmunge /usr/sbin
pathmunge /usr/local/sbin
fi

pathmunge /usr/X11R6/bin after

unset pathmunge

# No core files by default
ulimit -S -c 0 > /dev/null 2>&1

USER="`id -un`"
LOGNAME=$USER
MAIL="/var/spool/mail/$USER"

HOSTNAME=`/bin/hostname`
HISTSIZE=1000

if [ -z "$INPUTRC" -a ! -f "$HOME/.inputrc" ]; then
INPUTRC=/etc/inputrc
fi

export PATH USER LOGNAME MAIL HOSTNAME HISTSIZE INPUTRC

for i in /etc/profile.d/*.sh ; do
if [ -r "$i" ]; then
. $i
fi
done

unset i


and the /rc.local looks like this:

#!/bin/sh
#
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.

touch /var/lock/subsys/local

PATH=/usr/java/j2re1.4.2_03/bin:$PATH
JAVA_HOME=/usr/java/j2re1.4.2_03
export JAVA_HOME
export PATH

any help would be great, thanks in advance!

Last edited by lowlyfe; 02-15-2004 at 01:30 PM.
 
Old 02-15-2004, 01:54 PM   #9
lowlyfe
LQ Newbie
 
Registered: Feb 2004
Location: Wisconsin
Distribution: Suse 9.2 Slackware 10.1 Mandrake 10
Posts: 3

Rep: Reputation: 0
nevermind, I guess i just needed to restart. oops
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LimeWare installation problem bluedarkness Linux - Software 5 12-03-2004 09:26 AM
Limeware and Java Nightmare HadesThunder Linux - Software 16 11-23-2004 07:47 PM
mozilla 1.4.1 no sound with java2 eeverde Linux - Newbie 1 08-07-2004 02:30 AM
Problems instaling Limeware. What is a VM? Draylath Linux - Newbie 5 06-03-2004 09:11 AM
limeware Synth218 Linux - Software 1 05-26-2003 09:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration